PDA

View Full Version : GIMP felimage noise plugin on modern Ubuntu (e.g. 13.10)



SumnerH
02-13-2014, 12:29 AM
The felimage noise plugin is great for generating noise for mountain heightfields and other mapping purposes, but it doesn't compile out of the box on modern Ubuntu. Here's what I had to do to get it to work.

1. Make sure that you have libgimp2.0-dev and libglib2.0-dev installed:

sudo apt-get install libgimp2.0-dev libglib2.0-dev

If one of those fails with a message saying it's already installed, that's fine.

2. Download the felimage package from: Felimage plugins for the GIMP - Browse /Felimage noise Gimp plugin/0.1.1 at SourceForge.net (http://sourceforge.net/projects/fimg-gmplugins/files/Felimage%20noise%20Gimp%20plugin/0.1.1/)

3. Extract it into a subdirectory:

tar xvzf /path/to/felimage-noise-0.1.1.tar.gz

cd felimage-noise-0.1.1/

./configure

make

4. The make will fail, with this message:

/usr/bin/ld: render.o: undefined reference to symbol 'cos@@GLIBC_2.0'
/lib/i386-linux-gnu/libm.so.6: error adding symbols: DSO missing from command line


The problem is that you need to add the math library, "-lm", to the command line by hand.

cd src

gcc -g -O2 -Wall -o felimage-noise basis.o cell_3d.o cell_4d.o cell_5d.o interface.o lnoise_3d.o lnoise_4d.o lnoise_5d.o loadconf.o main.o poisson.o random.o render.o saveconf.o snoise_3d.o snoise_4d.o snoise_5d.o -lgimpui-2.0 -lgimpwidgets-2.0 -lgimpmodule-2.0 -lgimp-2.0 -lgimpmath-2.0 -lgimpconfig-2.0 -lgimpcolor-2.0 -lgimpbase-2.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0 -lm

(That last line is just what it tried to run before but with "-lm" added at the end--if you have an unusual installation, use your gcc line but add -lm to it)

cd ..

sudo make install



That's it. Restart gimp, go to Filters->Noise and you should see felimage in the list!