1. This will be long.  This will be hard.  There will be blood.  If you're new to Photoshop then this will probably confuse you many times along the way...I even messed up once and I wrote this thing.  For the rookies out there I'll be as descriptive as possible...so make sure that you read very carefully.  For the pros, you should be able to follow along quite easily without reading as intently.

2. SETTING UP THE IMAGE  

3. File > New = use the preset size of “Letter”.  For those of you who might have accidentally removed the preset size then make your image 2550 wide by 3300 high (or 8.5 x 11 inches), resolution = 300 ppi (points per inch), RGB color in 8 bit mode.

4. Make sure that black and white are the foreground and background colors (hit “D” on the keyboard).

5. Lastly, let's turn the image on its side so at the top of the screen click on Image > Rotate Canvas and pick either 90 CW (clockwise) or 90 CCW (counter-clockwise).

6. TERRAIN

7. Click on the Background layer then Filter > Render > Clouds.

8. Duplicate this layer (it will be named Background copy), either use Layer > Duplicate Layer or click hold, and drag the layer to the little square within a square icon at the bottom of the layer stack.

9. Any changes that we make will be made on this layer instead of our original clouds on the Background layer.

10. Grab the Brush tool (if you see a pencil then right click on that and change it).  At the top left of the screen you will see a little image of what tip you have and next to it is a little upside down triangle...click on that triangle to bring up the Brush Preset Picker.  Scroll down the list to the Airbrush Soft Round 300.  At the top of the screen you will see the word “Flow” and a box next to it with a number and a tiny triangle...click on the triangle and a slider will appear.  Grab the slider and move it to the left until the number changes from 100% to 10%.

11. Now we are going to paint in a rough river valley with black and then we are going to go over everything else with white.  We will leave some gray around the valley edges.

12. Duplicate this layer (it will be named Background copy 2) and rename it to “Hills”.  To do this double-click on the words that say Background copy 2 and then enter the new text (Hills).  Duplicate this layer and rename it to “Mountains”.  Lastly, hide this layer by poking out the little eye on the layer stack and click on the Hills layer.

13. The next few steps can be very confusing for those not familiar with this filter and it does not have a counterpart in other programs like Paint Shop Pro, Photoshop Elements, Painter, Paint.net, or MSPaint.  I believe that Gimp does have something similar but I'm not sure.  Make sure that you read very carefully so that you understand it all.

14. Filter > Render > Lighting Effects.  Use the settings in the attached image. What confuses most people is that there are 5 lights (one in each corner and one in the middle).  To add a light click on the light bulb, hold, and drag it into the preview image.  All are Omni lights and all have the same settings: Intensity = 6, Gloss = -100, Material = 100, Exposure = 0, Ambience = 8.  Make sure that the Texture Channel is set properly to Red, “White is high” is checked,  and that the Height is all the way up to 100 (Mountainous).  Make sure that the ring around each white dot covers its quarter of the image and that the center dot extends to overlap with the others.  This gives our terrain a bit of depth even though it sort of looks like stone.  Lastly, set the layer's blend mode to Overlay.

15. Click on the Mountains layer.  Filter > Render > Lighting Effects...use the setting in the attached image.  Here we have one spotlight coming in from the bottom right.  Intensity is 13, Focus is 100, Gloss is 100, Material is 100, Exposure is 0, Ambience is 8, Texture Channel is Red, “White is high” is checked, and Height is all the way up to 100.  Lastly, set the layer's blend mode to overlay.

16. Create a new layer and rename it “Land color”.  Fill this layer with your favorite green color...I went with a sage green, hex code 555A41 (85, 90, 65).  

17. Create a new layer and rename it “Adjust1”.  Hit the D key to reset your colors to black and white.  Change the black to a dark green, hex code 142800 (RGB 20, 40, 0) and change the white to a yellow, hex code F0DC82 (RGB 240, 220, 130).  Filter > Render > Clouds.  Set the blend mode of the layer to soft light with a 50% opacity.

18. Create a new layer and rename it “Adjust2”.  Change the green to hex code 506E32 (RGB 80, 110, 50) and change the yellow to hex code 807040 (RGB 128, 112, 64).  Hit ctrl+f to repeat the clouds.  Set the blend mode of the layer to Soft Light at 50% opacity.

19. Click on the Hills layer (in the layer stack).  Click, hold, and drag this layer up to the top of the layer stack.  Repeat for the Mountains layer.  Set the blend mode of the Hills and Mountains layer to Overlay with a 50% opacity.

20. Duplicate the Background layer and move it to the top of the layer stack.  Rename this layer to “Bumps”.

21. Select > Color Range = use white with a fuzziness of 200.  NOTE: Photoshop Elements does not have this function so skip this step.  Select > Inverse.  Hit the delete key then deselect.  Set the fill of the layer to zero and then add a layer style of Bevel and Emboss.  Style will be Emboss, Technique is Smooth, Depth is 50%, Direction is up, Size is 250, Angle is -45, Altitude is 30, Highlight Mode is white at Color Dodge and 75% opacity, Shadow Mode is black at Multiply and 75% opacity.  On this layer you can use the airbrush and add in more hills or erase hills if you want.

22. Our base terrain is done and you should have 8 layers: Background, Background copy, Land color, Adjust1, Adjust2, Hills, Mountains, and Bumps.

23. RIVER

24. These steps are optional but I figure that I'd better cover it.

25. Click on the Pencil Tool.  If you only see the Brush Tool then right click on that and change it to the pencil.  You can choose any size tip that you want, I went with the Hard Round 19 pixels.  We have to do one minor edit to our tip so at the top of the screen click on Window > Brushes.  This brings up the Brush Editor window.  On this window click on the words that say “Brush Tip Shape”.  At the bottom of this screen find the word that says “Spacing” and set this to 1%  

26. Create a new layer and rename it to “River base”.

27. Using white, draw in some squiggly lines to define the edge of the river and make sure that they reach all the way to the edge.  Grab the Paint Bucket Tool.  If you only see the Gradient Tool then right click on that and change it.  Fill in the space between your lines.

28. Duplicate this layer (it becomes River base copy) and then hide the River base layer.  The reason that we make duplicates is that if we mess up or don't like something then we can go back and start over.  Filter > Blur > Gaussian Blur = 25.

29. This layer will have 4 layer styles but first set the fill of the layer to zero (on the layer stack).  First there is a Pattern overlay. Find a good, realistic-looking water pattern on the web.  I got mine at the Dunjinni.com user forums and it is called RealWater1bLg_dgw.png (don't worry I have included it in the zip file that accompanies this tut).  I set the mode to Screen and the scale to 25%.  Next we add a Color Overlay of something teal, hex code 4B7D7D (RGB 75, 125, 125).  The mode is normal and the opacity is 90%.  I want the middle of the river to be deeper, and therefore darker, so add an Inner Glow.  I use a medium gray, hex code 606060 (RGB 96, 96, 96).  The mode is Multiply, the size is 100, and poke the button for Center instead of the default Edge.  Lastly, we start adding in some wet sand with an Inner Shadow so I went with a sand color, hex code E9E2B4 (RGB 233, 226, 180).  The mode is Color, the angle is -45, distance is 0, choke is 33, size is 76.  When we do the next layer, most of this will barely be noticeable.  

30. Duplicate this layer (it becomes River base copy 2).  On the layer stack, right click on this layer and choose “Clear layer style”.  This layer will have 2 layer styles.  First, we put down some good looking mud as a Pattern overlay.  I used something called mud_grass found here: http://local.wasp.uwa.edu.au/~pbourke/texture_colour/mud/index2.html  I then reduce the scale to 75%.  Next, I want my mud to be wet so it needs to be darkened with a Color overlay of something...I went with a medium gray, hex code 84817B (RGB 132, 129, 123).  I set the mode to Multiply.

31. Duplicate this layer (it becomes River base copy 3).  On the layer stack, right click on this layer and choose Clear Layer Style.  Ctrl+click on the River base layer to load it as a selection.  Select > Modify > Contract = 50. Select > Feather = 50.  Select > Inverse.  Hit the delete key then deselect.  What this does is cut our river away from the edge because we want our edges to be shallow (and therefore we can see some of that yummy mud).  Lastly, set the fill of this layer to zero (on the layer stack).

32. This layer gets 3 layer styles.  First, we put in a Color overlay of a medium gray with a hint of blue, hex code 505A64 (RGB 80, 90, 100).  Set the opacity at 90%.  Second, we add an Inner glow of a medium gray, hex code 606060 (RGB 96, 96, 96).  Set the mode to overlay, opacity at 50%, and size is 100.  The reason that our gray is not 50% gray is because in overlay mode it is invisible; so by setting it to be darker than 50% gray the overlay acts to darken things up.  Lastly, we add an Outer glow to enhance our sandy river bank.  I went with a sand color, hex code E9E2B4 (RGB 233, 226, 180).  Mode is soft light, opacity is 100%, and size is 100.  This might not look like much but just wait to see what happens after the next few steps.  You will notice that I went and smoothed my bumps with a big airbrush.

33. Let's add some eye candy and put in that sandy river bank.  Create a new layer, rename it to “Sand1”, and fill it with black.  Ctrl+click on the River base layer.  Select > Modify > Expand = 100.  Create a new layer and then fill it with white then deselect.  Merge down (ctrl+e).  Filter > Pixelate > Crystallize = 12.  Filter > Pixelate > Crystallize = 6.  Filter > Pixelate > Crystallize = 3.

34. At the top of the screen click on Image > Adjustments > Brightness/Contrast.  Move the slider for contrast all the way up to 100.  Filter > Brush Strokes > Spatter = use the default settings.  Select > Color range = black with a fuzziness of 200.  Hit the delete key and deselect.  Move this layer underneath the River base copy layer.

35. This layer will have 5 layer styles.  First we put down a pattern, I like that mud grass so let's use that again...and again set the scale at 75%.  Since this doesn't look like sand we need some color so add a color overlay of something yellow, I went with hex code F0DC82 (RGB 240, 220, 130).  I set the mode at Linear dodge and the opacity at 33%.  I want this river to look more like a stream than a full-blown river and so it will have banks rather than just being kind of flat so let's add a Bevel and Emboss.  Inner bevel, chisel soft, depth is 50%, direction is down, size is 100, angle is -45, altitude is 30, highlight mode and shadow mode are both the same color of brown, hex code 5A461E (RGB 90, 70, 30), highlight mode is at screen and shadow mode is at multiply and both are at 100%.  We add a contour as well; on that window you will see an image that looks like a square with part of it white and part of it gray with a little triangle next to it...click on that triangle and a screen will pop up so scroll down and choose the Half Round.  Next, we add an Inner glow to enhance the shadow effect.  I went with the same brown as in the bevel, hex code 5A461E (RGB 90, 70, 30).  Mode is normal, size is 150, range is 40, and the contour is the half round.  Lastly, we add an outer glow of something tan, hex code 8C8250 (RGB 140, 130, 80).  Mode is normal, opacity is 50%, and size is 250.

36. Now that looks much better.  The screen edges kind of mess up the bevel so grab the Eraser tool.  At the top of the screen make sure that you are in brush mode, set the flow to 5%, and pick the airbrush soft round 300 tip.  At the screen edges do some light erasing to get the bevel back under control...this will take a certain kind of touch so you will need to play with it and undo thins until you get it right.

37. You know me and that I like to over-complicate things :)  So duplicate this layer and clear the layer styles.  Set the fill to zero and add a pattern overlay of Gouache Light on Watercolor; it comes with Photoshop...if you don't see it then you will have to load it in from the Presets folder (Edit > Preset Manager > Patterns > click the Load button and then navigate your way to the Adobe/Photoshop/Presets/Patterns folder and load all of those in).  Set the mode to hard light and the opacity at 50%.

38. Click back on the River base copy 3 layer.  Duplicate this layer and rename it to “Ripples”.  Clear the layer styles (right click on this layer in the layer stack).  Set the fill to zero.  Add a layer style of Bevel and Emboss.  Leave all of the settings alone except for shadow mode...set that at zero opacity.  Add a Texture to that bevel...pick something that you like.  I went with something called crystal4 and set the depth at +18.  This pattern is included in the zip that comes with the tut.

39. The last part of our river will be to put some ripples around the edge.  So create a new layer and rename it to “Edge ripples”.  

40. This part can be confusing for rookies.  Ctrl+click on the River base copy layer in the layer stack.  Click on the Paths tab (or open it if you have turned it off). At the bottom of the paths window click on “Make work path from selection”. Click on the Brush tool and then at the top of the screen click that little triangle to open the Brush Picker.  Scroll down the list and pick the one called “Ornament 1” (it looks like a little wave or tilda).  If you don't see this brush listed then load it via the Preset manager following the steps I showed you for loading up the patterns...but this time go to the Brushes folder instead of the Pattern folder.  We need to modify this brush tip so open the Brushes window (Window > Brushes). Click on Brush Tip Shape and change the spacing to 100%.  Click on Shape Dynamics and set the size jitter to 100%, angle jitter at 5% (set the control for this to Direction), and roundness jitter at 100%.  Click on Scattering and set the Scatter to around 300 and the Count is 2.  Make sure that white is the foreground color. Still on the Paths window, at the bottom, click on “Stroke path with brush”.  When done, drag the path to the trash can at the bottom of the screen.

41. Click back on the Layers tab.  Filter > Distort > Ripple = use Large ripples.  Ctrl-click on the River base layer.  Select > Inverse.  Hit the delete key and deselect.  This erases white ripples on the bank.  Create a new layer and then Filter > Render > Clouds.  Select > Color range = black with a fuzziness of 200.  Delete this layer by dragging it to the trash can at the bottom of the screen. Now hit the delete key a few times...I did it 10 times, then deselect.  This erases randomly and cuts out big chunks of ripples creating something quite random looking.  If there are still some ugly ripples left then just erase them with the Eraser tool (make sure that you use a small tip like 5-9 pixels).  

42. Our river is finally done.  It looks pretty good, too.  If you want to you can play with some pattern overlays on the River base copy 3 layer.

43. On the layer stack, at the bottom there is an icon that looks like a folder...click on that.  Rename it to “Terrain”.  Click on the top layer in the stack, it should be “Edge ripples”.  Click, hold, and drag this layer into the folder.  In order the keep the layers in their proper order, continue going down the list putting each layer into the folder from top to bottom.  Don't put the Background layer in.  To the left of the folder name is a little triangle, click that to collapse the view.  Now we have more space in our layer stack.  

44. Oh, I forgot something.  Click in the Sand 1 layer.  Ctrl+click on the layer in the layer stack.  Select > Feather = 10.  Select > Inverse.  Hit the delete key a few times then click on the Sand 2 layer.  Hit the delete key a few more times then deselect.

45. TOWN PLANNING

46. Now it's time to start thinking about our town and how it would be laid out.  The first thing I look for is the high ground and plan to put a castle or fort there.  Create a new layer and rename it to “Layout”.  Grab the Pencil tool and draw a circle there.  Next, I think about the walls and draw a line around an area that is fairly elevated but nothing too strict. I'll put my nobles here.  I draw another, wider ring, to encompass a larger area for my merchants to live and work.  Lastly, I draw out an even wider ring to encompass the rest of the town.  

47. A big city will have docks, grain mill, lumber mill, and boatyard on the river and probably some clay pits for potters.  Towns are smaller so they wouldn't have as many things there and villages are smaller still and might have at most two of these things.  Since we're doing a village here I'm going to plan on a grain mill and pottery.  Basic necessities like food always come first, whether it be from hunting, fishing, farming or trading.  Raw materials come next...wood, iron, wool, stone, etc.  Industries like carpenter, mason, weaver, and blacksmith come third (without food there are no people and without iron there is no smithy).  Defenses come fourth (without a  mason there is no castle).  Fancy amenities, like a haberdasher or magic shop, come last (without security the merchants won't make a permanent residence there).

48. I'm doing a village here and it will be inside of a fort...sort of a frontier village thing.  So let's lay in some rough idea of roads.  Create a new layer and rename it to “Roads”.  Grab the Brush tool, it doesn't matter right now what size tip that you use to draw your roads since we're not ready to worry about scale just yet.  Start at the castle and draw a road that leads away from here to the river somehow.  Cross over the river and continue to the edge of the screen.  This will be our “Main Street”.  Taking into account how we laid out our rings for the various areas, put one road that goes from the main street through the area for nobles.  Put in a road for the merchant area and then a road for the peasant area.  Now we can start adding in smaller streets and alleys.  

49. Once we have a decent looking road layout we can start thinking about what buildings go where.  Create a new layer and rename it to “Notes”. Since I'm building a frontier fort I'm going to put in some industries that support the defenses...tanner (cures hides), armoury (armor and shields), bowyer (makes bows), fletcher (makes arrows), and shield painter (designs heraldry and makes basic non-metal shields).  I want these buildings to be rather close to one another, my personal preference for a small village.  A large city might have these buildings on opposite sides of town or have many of them scattered around.  The exception to this is the tanner – it's a very smelly place and people usually don't want it too close to where they are trying to eat their dinner.  

50. There are other smelly buildings like dyer (colors cloth, leather, etc), launderer (collects chamber pots from window sills to clean clothes), slaughterhouse, soap-maker (boiling lye is smelly), chandler (they didn't have potpourri candles back then), paper-maker (not sure why but it is smelly), oiler/oynter (boils blubber for lamp oil), butterer (stale milk, cheese, and butter is smelly), etc. so I try to keep them together and away from the residences.  Since nobles are usually a rather sedentary bunch they like to sleep in so there won't be a smithy or carpenter nearby waking them up in the morning.  Scandalous lot that they are, smithies wouldn't want to be near them anyway.  So I use the Pencil tool and draw little circles for where I want to put things.  I also write in what is what so that I don't forget.

51. There are some good-smelling places like the bakery, brewer, vintner (makes wine), spice shop, and the perfumery.  There are some quiet places like the scribe, book-binder, library, seamstress (plain dresses), cobbler, weaver, monastery, abbey, nunnery, church, shrine, etc.  The barracks usually needs lots of space for their training yard and if you want to have a stables for the cavalry then you're going to need a large amount of space (unless they train out in the countryside), the archery range also takes up some space.  Nobody wants to live near the jail, courthouse, stockade, gibbet, dong-farmer (cleans up after the horses), or other such vile places.  Oh, and don't put in a thieves quarter or thieves den as these places are meant to be secret and can usually be found near the wharf, brothel, slums, underground, etc...if there is a run-down part of town you can safely assume that the thieves live there...although, most would say that the nobles are the real thieves :)

52. My fort here is going to be arranged as double motte and bailey...an inner wall, outer wall, and keep (manor house).  The inner wall around the keep will be stone with a bastion gate.  The outer wall will be a palisade wall that has houses built up to the edge of it (patrol guards will walk around on the roof tops) so this acts as a double wall, in essence...once you break through the wall you still have to climb over the beds, trip on the deerskin rug, kick a chicken out of the way, open the door (which acts as a choke point) and then go about your merry berserking.  Because of this most invaders will just try to knock the main gates down (easier access to the booty and peasants living up against the wall don't have booty...they have fleas).

53. Where the outer wall crosses the main street will be where the main gate is.  Merchants are a greedy bunch so they try to maximize their opportunities by putting their shops near the main gate on the main street.  Big cities will have many gates and many merchant areas.  So I draw some more little circles.  Often, merchants will also stake out some ground around the main square.  

54. So now we have a good basic layout – walls, castle, industries, merchants, nobles away from noise, smelly stuff away from residences, and a mill on the river.  Often merchants lived over top of the their shops but since this is a village they haven't yet needed to build upward...they build next door.  So the remaining space will all be houses, shacks, and huts.  

55. Next, I always put in some kind of inn – which always has a pub in it and frequently a brothel nearby as well as some type of bath house.  I'll usually put this just inside or outside of the main gate.  Bigger towns will have one in the merchant quarter, noble quarter, docks area, main square, etc. depending on the city size.  Towns and cities will also have warehouses.

56. Lastly, if you have a wooden fort you might want to consider putting in a fire brigade.  You can put in some wells around the residential areas as well but don't overdo it...I try to go with 1 well = 20 families/houses.  I'm sure that there is some concrete information on that somewhere but I don't care all that much to research it :)

57. There are other occupations for larger towns to have: rectifier (whiskey, brandy, etc), longshoreman/dock-worker (loads/unloads ships), press-gang/crimp (gathers up idle men and puts them to work, often aboard a ship) miner, quarry (stone-cutter, mason), brick-maker, paviour (makes and installs cobblestones for streets), tiler (makes roof tiles), turner (makes the hafts of pole-arms, table legs, stuff like that),  cooper (makes barrels), wainwright (makes and repairs wagons), wheelwright (often combined with the wainwright), carriage-maker (fancy carriages for the nobles), cabinet-maker (makes cabinets, chests, and wardrobes), carver (wooden decorations for things and ships), forge (basic iron stuff like plows and spades and wagon fittings), tinker (gears, trinkets, fixes pots, small-time forge), artificer (makes clever things like music boxes and clocks), locksmith, liner (marks out property boundaries), permit office, engineering office, census-taker, barrister (lawyer), tax collector, money-lender, dry goods (sacks, unfinished cloth and leather), general goods (picks, shovels, hooks, torches, ropes, nails, hammers, axes, saws, buckets, etc), outfitter (packs, tents, bedrolls, stuff like that), draper (sells cloth), upholder (makes furniture cushions, pillows, etc.), dress-maker (nice dresses), tailor, milliner (makes ladies hats), shoe-maker/cord-wainer, belt-maker, hat-maker, glove-maker, hosier, furrier, corsetiere, peruker (men's wigs), wig-maker, mercer (textiles), jeweler, lapidary (cuts gems so that they just don't break into a million pieces),  teamsters hall,  artists guild (painter, portraitist, sculptor, statuer, etc), school (teacher, school-marm, rector), college (professor, philosopher, dean, librarian), music hall, theatre (set-dresser, costumer), amphitheatre, harper (makes harps), reeder (makes woodwinds), lists (for jousting), arena, circus-maximus (chariot races), cemetery, silverer/pewterer (makes forks and spoons and plates and stuff), cutler (cutlery), comb-maker/ivorist, purser (makes purses), alchemist, magic shops for everything (rod-maker, wand-maker, staff-maker, talismaner, reagents), scroll-maker (usually vellum), potion-maker, healer, herbalist/apothecary, mid-wife, doctor, dentist, barber, witch-doctor, shaman, witch/warlock, druid, mystic/gypsy (palm-reader, tarot cards, fortune-teller, stuff like that), glass-blower (makes stemware, sheet glass, glass sculptures), glazier (cuts, installs, and repairs glass windows), glass-artist (designs, cuts, makes, and installs stained glass and knows the secret formulas for making the colors, before metals were introduced we used gemstones and various chemicals), tile-setter (tile floors and mosaics), ceramicist (fancy bowls, plates, and stuff), rug-maker (whatever that is called, I forget at the moment), tapicer (tapestries), minter (makes coins), sign-painter, pasteler (makes pastries), confectioner (candies, sweet-meats, stuff like that), salter (salts hams), smoker (smokes meats, makes jerky, rations),  forester, hayward (cuts grasses for straw and hay), saddle-maker/saddler, leather-worker, tack shop (horse supplies), lancier, lorimer (bridles, bits, harnesses), farrier (horseshoes), larder (same as granary but has been used to refer to something more “in the home” rather than public), tobacconist (sells tobacco and makes pipes), fishmonger (sells the catch of the day), atilliator (crossbows), swordsmith, brazier (brass-worker), biller (makes bills, halberds), bell-maker, cartographer, sailmaker, port authority, Nordic towns have a mead hall and/or longhouse with cooks and serving wenches as well as sleigh-makers, then theres the numerous nefarious occupations of the underworld (Secret Master, assassin, spy, smuggler, fence, pirate, safecracker/yegg, bandit, swindler, poisoner, slaver, burglar, highwayman, thug, cutpurse, footpad, thief, henchman, ruffian, and my favorite...defenestrator who throws people out of high windows), the various merchant occupations (Merchant Prince, magnate, tycoon, burgher, banker, bursar, exporter, broker, shipper, dealer, trader, shopkeep, vendor, hauler, marketer, clerk), various labor jobs (Grand Master, guild leader, master, factor, artisan, foreman, craftsman, miller, teamster, apprentice, laborer, peasant, serf), the army (field marshal, general, colonel, commander, captain, major, lieutenant, chief, sergeant, corporal, squire, pikeman, billman, halbardier, lancer, slinger, javeliner, archer, arquebusier, blunderbusser, musketeer, artilleryman, catapultist, sapper, engineer for various siege engines, runner, drummer, standard-bearer, scout, quarter-master, heavy infantry, light infantry, phalanx, skirmisher, berserker, heavy cavalry, light cavalry, elephant-rider, rider for anything really), the navy (admiral, commodore, captain, mate, ensign, officer, marine, seaman),  airborne armies like griffon-riders (wing commander, captain, flight leader, formation leader, group leader, and airman), the clergy (Pope, patriarch, cardinal, archbishop, bishop, inquisitor, priest, vicar, deacon, monsignor, chaplain, curate, parson, pastor, abbot, monk/nun, brother/sister, acolyte), the nobility (emperor, king, prince, archduke, duke, marquis/margrave, earl, count, viscount, baron, baronet, coronet, vidame, castellan, steward, knight), various household servants (butler, maid, lady-in-waiting, chef, cook, handy-man, gardener, advisor, stable-master, stable-boy, horse-trainer, chauffeur, man-at-arms, housecarl, falconer, hunt-master, page, messenger, pigeon-keeper, reeve, chamberlain, groom), various entertainers (actor, playwright, writer, composer, singer, flutist, lutist, lyrist, harpist, conductor, choir-master, story-teller, jester, acrobat, dancer, various sideshow freaks and animal-tamers, wrestler, gladiator, olympian, charioteer, you can make up some other sports if you want like dwarf-tossing, witch-hunting, shin-kicking, etc), town-crier/barker, printer (public notices and wanted posters), lamp-lighter (lights and snuffs torches and oil lamps on the streets), chimney-sweep, rat-catcher, charcoal-maker (for those who are running later medieval period stories where gunpowder is present), papyrus-maker, parchmenter (existed until paper became commonplace), warden, jailer, guard, headsman, torturer, bounty-hunter, hunter, tracker, trapper, pathfinder, trailblazer, farmers and herders and ranchers for everything under the sun, various janitors and attendants and clerks, pseudo-jobs like town-drunk, beggar, “escort”, rabble-rouser, hell-raiser, hidden-identity guy (like Zorro), hermit, crone, hag, “that crazy guy”, “the blind lady who sees the future”, “the deaf guy who reads lips”, “the weatherman with the broken leg”, “the good luck charm”, “the creepy lady who is always staring at people and saying 'doom'”, “the weird old guy who always steps in and out of the shadows”, the gimp, the limp, the really strong dumb guy, and the list goes on...these are the ones that I know of but I'm sure that you can make up more.

58. Since I'm doing a village I want my people to be small-time farmers and herders so there will need to be some fields, pastures, grazing land for the sheep, and what the heck, I'll put in some orchards too so I need to make sure that I keep some open land.  If you're happy with your general road layout, create a new layer and then click on the Brush tool.  

59. Now we have to start thinking about scale.  How wide of an area does the image show?  Is it a few hundred yards for a tiny village or is it a much larger distance (mile or kilometer) for a big city?  Whatever you decide on is important because your brush tip size will be relevant here.  If you're doing a big city and you pick a really big brush tip then the scale will be off and you'll have to redo your roads.  So the next thing you have to figure out is how much does 1 pixel represent?  For a big city, 1 pixel = 5 to 10 feet (for me) and a village will be more like 1 pixel = 6 inches to 1 foot.  If you want you can go smaller but I'm not very good at that scale and this will result in a very large image.  

60. ROADS

61. So with my village in mind I choose a 27 pixel soft round brush tip to represent 15 foot wide roads (wide enough for two carts to go by each other), since this is an odd number I set it to 30.  This means that my scale is going to be 1 pixel = 6 inches.  I start painting in my roads (color doesn't matter) and when done I apply some layer styles; Pattern overlay to give it some texture (I went with the mud grass again at 50% opacity), Color overlay of something tan (I went with 9C8860, RGB 156, 136, 96 at 33% opacity), outer glow and inner glow are the same tan color but outer glow is set to normal at 50% opacity and inner glow is set to screen at 33% opacity (it is also set to center and not edge), I add an inner shadow of the same tan to put some mud around the inner edges (distance is zero).  Lastly, I set the fill of the layer to zero to remove any of the paint color.  These roads might not final but at least they look good and their placement is near final.  Later, we might have to erase and redraw in some places.

62. CASTLE

63. With that done, the only thing that I really know is where I want to put the castle...on the highest ground.  So create a new layer, set white as the foreground color, click the pencil tool, and draw in a castle shape.  Not so easy is it?  What I do is to pick the 24 pixel hard square tip.  In the brush editor window I set the spacing to 300%, and then mess around with the shape dynamics of size jitter and roundness jitter (size jitter will give varying size squares and the roundness jitter will produce rectangles and combined we get varying size of squares and rectangles).  Then I draw some lines.  What results is a bunch of blocks that I will use to start shaping a castle.

64. Next, I grab the Magic Wand tool (it looks like a dandelion).  I click on a shape and drag it into a position around one of the bigger chunks, I'll rotate if necessary (Edit > Transform > Rotate), then deselect (ctrl+d).  I keep doing this until I have something that looks halfway decent.  As you do this you will eventually begin to “see” with your imagination a castle shape form...it's sort of like building a castle brick by brick.  Once this is done erase the unused blocks.

65. Add a layer style of pattern overlay of some rocks, blocks, or bricks pattern (I use  something called rock10...it's in the zip file).  You'll have to set the scale of the pattern to suit you so I went with 10%.  This pattern is far too teal so I add a color overlay of a dark brown, hex code 4B4000 (RGB 75, 64, 0) set to color at 50% opacity.  I like to do my castle as a big rectangle on one layer (called Castle) and then towers on another layer (called Castle towers).  Next I'll add a stroke; black, outside, size is 2.  Lastly, I'll add an inner glow of white set to screen at 75% opacity, size is 2 and choke is 100 to act as a parapet.  Do not rotate anything yet.

66. Create a new layer and rename it to “Castle roof”.  Grab the Rectangular Marquee tool.  Click, hold, and drag out a rectangle to be used as a roof for a section of the castle.  Click the paint bucket tool and fill this layer then deselect.

67. Add some layer styles.  First, we get a pattern overlay of something that looks like roof tiles, shingles, or wooden planks (I use “red shingle roof” in the zip file) at a scale of 15%.  I like my rich people to live under copper roofs so I add a color overlay of blue, hex code 004064 (RGB 0, 64, 100) set to color mode. This is too dark and so I add an inner glow of white; mode is screen at 25% opacity and size is 30.  Next, I add an inner bevel, chisel soft, size is 21, angle is -45, altitude is 30,  highlight mode is white at screen 50% opacity.  Now it looks like weathered copper.  Lastly, I'll add a 2-pixel black stroke to the outside.

68. If you want to rotate the castle then link the Castle layer and Castle tower layer and merge them together then link to the castle roof layer.  You do this by looking at the layer stack, click on the castle layer, you will see an eye and a paintbrush, directly above the paintbrush is the Castle tower layer but it has an empty box instead of a paintbrush.  If you click in the empty box a chain will appear...the layers are now linked together.  Merge down (ctrl+e) and rename the layer to “Castle”.  Click on the Castle roof layer and link it to the Castle layer.  Now you can rotate and preserve any bevel properties on the roof (highlight and shadow) but not pattern, it always stays oriented to the page unless rasterized (the layer style has to become part of the layer itself instead of just being an effect).  When we merged our Castle and Castle tower layers this rasterized the layer styles and allows us to rotate the castle and since our roof is linked but not merged the bevel will retain its orientation to the sun.

69. CURTAIN WALL

70. Now I need to put in a block wall around my castle.  Keeping image scale in mind I choose the 6 pixel hard round pencil tip and draw a curtain wall.  If you want to keep lines straight then click once to place a dot then hold down the shift key and then click again somewhere else on down the line.  If this were a big city I'd make my wall thicker but since this is a village I probably should not even have a block wall...but who cares :)  On the layer stack, right click on the castle layer and choose “copy layer style”.  Right click on the block wall layer and choose “paste layer style”.  

71. I want a gatehouse to cross the road leading in to my castle so I click on the castle layer.  I draw out a rectangle with the rectangle marquee tool and then fill with the paint bucket.  Since there are layer styles already built into this layer I don't have to do anything more unless I want to rotate the gatehouse.  Once I have rotated then I deselect.  If you try to rotate after deselecting then the whole layer will move.

72. PALISADE

73. Now I want to put in a wooden palisade to surround the rest of the city. Still with the pencil tool, I change the tip to the 3 pixel hard round tip.  I also make sure that the foreground color is white.  On the brush editor window I change the spacing to 200%.  Now I just draw lines, some straight, some wavy. Where the palisade crosses the main roads in and out of town I put in something square to form something of a gatehouse.  I'll put floorboards in these areas later. What we have are dotted lines.

74. Now we'll add some layer styles: stroke, 2 pixels, outside, and black; pattern overlay if you want just to break up the color (make sure that it is a grayscale pattern or a wood pattern, I used that mud grass again); I put a small inner bevel, chisel soft to sort of make it look like those pointed things you always see; and if you want then you can put in a drop shadow.

75. BRIDGES

76. Ok, so let's do the wooden bridges.  If these were to be stone bridges I would copy the layer style from the castle layer.  This will move us along a little bit and we'll learn some new techniques.  Create a new layer and rename it to “Bridges”.   

77. Grab the pencil tool and change the tip to something that is about the size of the tip we used for the roads.  I used a 30 pixel tip for roads so here I'll use the 24 pixel hard square and size it up to 30.  Make sure your image is zoomed so that the whole thing fits on screen and that the foreground color is black.  Create a new layer and rename it to “bridges”.  Hold down the shift key then click with the mouse on the left side of the screen and drag across to the right side.  Ctrl+click on this layer in the layer stack.  Duplicate this layer. Filter > Noise > Add Noise = 400%.  Filter > Blur > Motion Blur; set the angle to be perpendicular to our line (in this case that angle is 90 or -90) and the distance is 10.  Deselect (ctrl+d) and merge down (ctrl+e).  The reason that we had the selection is to contain the motion blur otherwise it would have gone outside of our line and created problems.  The reason that we use two layers is because of the selection; by containing it, we end up with some transparent pixels around the edges.  Now add a layer style of color overlay and pick a color that you like, I went with a dark tan, hex code 786450 (RGB 120, 100, 80) and set the mode to multiply at 67% opacity.  Lastly, add the 2 pixel outside black stroke.  Let's rasterize the layer so that we can rotate the bridges to fit our roads.  Create a new layer and link it to the bridge layer.  Drag this new layer (should be called Layer 1) underneath of the bridge layer in the layer stack.  Click on the bridge layer and merge down.

78. Grab the Rectangular Marquee tool and drag out a selection big enough to cross the river.  Click on the Move tool (it looks like a pointer).  Click, hold, and drag this chunk to where you roughly want it.  At the top of the screen click on Edit > Transform > Rotate.  Since we still have a selection, only that part will get rotated.  Click near a corner and drag to rotate the selection; try to get this bridge chunk to cross the river perpendicularly then click the checkmark at the top of the screen.  The rotating might have moved your bridge out of place so click on the Move tool again and drag it into place.  The reason that we made one long line is so that we can crop out chunks for other bridges.  So if you have other bridges then repeat this step.  If your bridge chunk comes out too long then just erase the bits that stick out.  If your bridge is too short then undo the steps (ctrl+shift+z) a few times and start with a bigger selection.  When done, erase the unused line.

79. On the layer stack, drag this layer underneath of the road layer.  Click on the Pencil tool and get the same tip that we used to make the palisade (3 pixel hard round) and on the brush editor, set the spacing to 200% again.  Now click on the palisade layer.  We're going to put a palisade along the edge of our bridge to reinforce that woodsy feel.  Where the bridge starts, click the mouse one time.  At the other end of the bridge, hold down the shift key then click once again.  Repeat this for the other side of the bridge.  If you have other bridges then put in some more dotted lines.

80. Click back on the Road layer and erase any road that goes over the bridge. Grab the Smudge tool, it looks like finger pointing.  If you don't see it then it is probably hiding under the Blur tool (which looks like a water drop) so right click on that and change it.  For the tip use the same thing as what we have been using for the roads.  Click, hold, and drag a short distance and the road will smudge over the top of our bridge.  Don't forget to do the other side.

81. Now we have to do something real tricky and I haven't yet mastered it ...making a shadow for this bridge.  The first thing we need to do is create a new layer and rename it to “Bridge shadow”.  On the layer stack move this layer beneath the bridge layer.  Click on the Pen tool (it looks like a calligraphy pen). Pick one end of the bridge and make a click near the end in the middle.  Click again where the water meets the sand.  Cross the river and click on this side where the water meets the land.  Click one last time on the middle of the bridge near the end.  Right click on the Pen tool and change it to the Covert point tool (it looks like an upside down V).  We will use the tool to modify our two interior nodes (points).  So click on one and hold down.  Drag the mouse and try to make the resulting curve “fit” the river bank.  You'll have to use your judgment here.  Do the same thing on the other interior node.  Now click on the Brush tool and pick the same tip that we have been using for roads (27 soft round scaled up to 30). Click on the Paths tab.  Make sure that your foreground color is black.  At the bottom of the Paths tab you will see a ring, when you hover your mouse over that it will say “Stroke path with brush”.  So click that and a line will appear along the path.  If you like what you have then drag that path (on the path stack) to the trash can.  If you don't like what you have then hit shift+ctrl+z to undo the stroke and then go back to editing your path with the various path tools (right click on the Covert tool and you will see the various tools available).  Click back on the Layers tab and make any small adjustments by hand to the shadow.  Filter > Blur > Gaussian Blur = 10.  Set the layer's opacity to 75%.

82. GATEHOUSES

83. Having learned this technique we can now use it to do the platforms for our gatehouses.  Instead of drawing out a line, though, what we will do is use the Rectangular Marquee tool to create a selection big enough to cover the gatehouse. Drag it out much bigger than you need because we'll be rotating it.  Click on the Paint Bucket tool and fill with black.  If you have other gatehouses then do the same thing for those on this layer as well. On the layer stack, make sure that this layer is underneath of the palisade layer.  Ctrl+click on this layer to load a selection, create a new layer, and do the noise and motion blur steps that we did for the bridges in step 77.  

84. Don't forget to merge down and deselect and don't forget the color overlay either...but I suggest using a slightly lighter color.  I went with a brown, hex code 645A50 (RGB 100, 90, 80), set the mode to linear light at 80% opacity.  I also added an inner glow, set the opacity at 25%, size at 15, and hit center instead of edge.  

85. Now in order to rotate these platforms to fit drag a selection around one platform and rotate it (Edit > Transform > Rotate).   Do this individually for each platform.  The last thing we do here is to erase the parts that stick out beyond the palisade.

86. FOOTINGS

87. If you have some really long bridges then you're going to need some support in the middle.  I choose to do mine in stone since they will be sitting in the river (wood will get pummeled and destroyed in floods).  Create a new layer and on the layer stack, drag this layer underneath of the bridge layer.  Grab a square pencil of a size big enough to be sturdy for your bridge.  Click, hold, and drag out a line big enough to be seen then add some layer styles.  Stroke, 2 pixels and black; pattern overlay of the rock10 pattern at 5% scale; color overlay of brown, hex code 4B4000 (RGB 75, 64, 0) set to hue at 75% opacity; and an inner bevel chisel soft.  Use the Marquee tool to make a selection around this chunk and rotate it to fit the bridge properly (that is, perpendicularly).  Draw out some more lines and marquee them and rotate them if necessary.  If you plan to put in a mill along the river, which I do, then we will be adding more footings later.

88. Hold down the ctrl key then click on the icon (in the layer stack) for “create a new layer”.  This will create a new layer underneath of the footings layer.  Rename this layer to “foam”.  Grab the Brush tool, if you do not see it then right click on the Pencil tool and change it.  Change the tip so the soft round 3 pixel tip and at the top of the screen, change the flow to 20%.  Now draw in some squiggly lines that make it look like water flowing around the footings.  If you plan to put in a mill then we will be doing some more squiggles later.

89. MILL

90. So let's get that out of the way right now.  We will start out with the same process that we used for the bridges so we will use a line as before and we will also use something bigger.  We will add a new wrinkle as well, though.  

91. First things first.  Create a new layer.  Now we need to keep our scale in mind.  Since my roads are roughly 10 feet wide and I used a 19 pixel tip that means that my scale is about 6 inches per pixel.  I'll start with a 20 pixel hard square tip on my pencil.  I'll make 4 clicks, one right next the other so that my building is 40 feet long.  Ctrl+click on this layer in the layer stack, duplicate this layer, Filter > Noise > Add Noise = 400%, Filter > Blur > Motion Blur = 90 degree, distance 10, deselect, merge down.  On the layer stack, right click on the bridge layer, choose “copy layer style”, click back on this mill layer and right click and select “paste layer style”.  This is going to be our roof but it's flat right now.  I could add an inner bevel chisel soft but I don't want that kind of roof for a simple village. Instead I'm going to add a gradient overlay to simulate the roof shading.  

92. This gradient is going to be a little tricky if you've never edited a gradient before.  So click on the cursive F at the bottom of the layer stack and pick “gradient overlay”.  The first thing that we are going to do is change the blend mode to overlay.  Next, you will see a little preview of what the gradient looks like, it should be black to white, so click on this.  This brings up the Gradient editor.  The sliders along the top are for opacity and we'll leave these alone for now.  The sliders along the bottom are for color.  Click, hold, and drag the white slider to the middle at 50.  If you hover your mouse just under the gradient then your pointer should turn into a hand and this will let you add a new slider if you click...so do that.  Click, hold, and drag this slider all the way to the right.  At the bottom of this screen you will see the word “color” with a box next to it.  Click on that box and bring up the Color Picker (you can also just double click on the slider).  Change this color to something of a light gray, I went with C0C0C0 (RGB 192, 192, 192).  Add another slider and change this to something of a medium gray, I went with A0A0A0 (RGB 160, 160, 160).  Now click, hold, and drag this slider to the middle at 50.  Here's the tricky part...a slight movement, either to the left or right, can change the gradient here.  What we want is a gradient that goes from black to medium gray then forms a hard edge with white and goes to light gray.  If we move just to the left a hair it will change to black to white, medium gray to light gray.  You might want to save this gradient for future use (we will be using it again).  To do this, type in a name (where it says “custom”) and lick on the “New” button.  The “Save” button saves the whole set of gradients to a file so that you can upload that file and share it with others.  Lastly, we need to think of where the sun is.  For me, it's in the lower right so I need to hit the box that says “Reverse”.  Do not rotate this shape just yet, we have more stuff to add.  

93. Grain mills are usually arranged with at least 2 floors, I'll explain in a bit. So make a larger square with the Rectangular Marquee tool (hold down the shift key to keep it square), create a new layer, grab the Paint Bucket tool and fill with black, then repeat the process from the previous step (noise, motion blur, color, gradient, etc).  On the layer stack, link this layer to the mill layer.  Create a new layer. Now change the pencil tip to something smaller and draw an upside down T, this is going to be our waterwheel.  Again, do the noise, motion blur, and color overlay but omit the gradient.  Link this layer up as well.  The reason that mills had multiple floors is that the moving parts were often loud and caused injuries (you could lose an arm in the gears and no one wants to buy bloody flour) so only the millers were allowed up here.  The waterwheel was connected to a horizontal beam with gears on it that connected to a vertical beam with gears on it which was connected to a horizontal grindstone to grind the grain into flour.  This didn't matter for saw mills, though.  The actual moving parts were usually on the top floor (I'm not sure why that is but it is) and the lower floors were for packaging, baking, and sleeping.  Having mills on the river was also a benefit because the moving parts often caused fires, especially in the dry winter air (lots of static electricity).

94. I also put a deck around the mill in the same way that I did the platforms for the gatehouses.  Then I put a railing in so that people won't fall into the river. This was just a 1 pixel pencil and then given a brown color overlay.  Next, I put in some steps.  For these, I did the usual noise, blur, color overlay, but the gradient was different...it was black to white, black to white, black to white, and black to white.  The black to white was gradual but there is that hard edge where white turns back in to black like we did for the mill roof...these hard edges were at 25, 50, and 75 so that means there is a black slider at 0, 25, 50, and 75 and a white slider at 25, 50, 75, and 100.  Lastly, I merged all of these layers together and then rotated it to fit the angle of the river.  I then finished it off with some more footings on that layer and some foam on that layer.  

95. With this done I went and moved the bridge and mill layers beneath the roads, then airbrushed some road onto the mill steps and bridges to look like wear spots.

96. HOUSING

97. Let's get started on this and really make some headway.  Oftentimes you will see the palisade walls have nothing under them except for things like hay, carts, and tools.  This is not very efficient for a growing village so I choose to make houses right up against the wall.  This allows more people to live there without having to move the walls or build upward or build new sections of town with more walls.  Of course the people who live here are in some serious danger in case of an attack but hey, the people who live here aren't rich either.  The guards have to have something to walk around on anyways so why not just drop a wall in and let people live there?  This part will be exactly like how we did the bridges.  Draw out a long line, ctrl+click, duplicate layer, noise, motion blur, deselect, merge down, color overlay, gradient overlay. 

98. This next bit is important because we didn't have to do it for the mill.  The layer styles have to be rasterized (this means that they become part of the layer instead of just being an effect upon the layer) or else the gradient overlay will get messed up once we start rotating.  So create a new layer, link it to the house layer, on the layer stack move this layer underneath the house layer, click on the house layer and merge down.  Now we can grab the Rectangular Marquee tool, drag out a selection, move, rotate, repeat.  

99. For individual houses we'll do exactly like we did for the mill...minus the layers for deck, railing, etc.  

100. I like to put some shacks in to denote lower class housing, again, just like the mill but the color overlay is slightly more yellowish.  

101. Lastly, I put in some huts with a hay-looking roof of a tan or yellow color overlay.  

102. Next, I grab the Brush tool, again with the 19 pixel soft round tip, and flesh out the roads some more by drawing paths up to the front doors.  Lastly, I add a pattern overlay of clouds set to overlay with a medium to low opacity to give some variation to the colors.

103. CHIMNEYS

104. Something is missing, though...chimneys.  This is going to get tedious but be patient and we'll eventually get through it.  Create a new layer and rename it to “chimney base”.  Grab the Pencil tool and use a small tip say 2 to 6 square.  Make black the foreground color and click once.  Add an inner glow of something gray, and add a stroke (2 pixels, black, outside).  Create a new layer and link it to this layer.  Move the new layer underneath.  Click on the chimney base layer and merge down.  Duplicate this layer (it becomes chimney base copy) then hide the chimney base layer...it will serve us in the next step.  Move and rotate the chimney base copy layer to fit alongside of a house somewhere and make sure that it overlaps the roof a little bit.  Each house needs at least one chimney so make a duplicate of the chimney base layer, move it rotate it then repeat for every house.  This is the tedious part.  

105. Once you have all of your chimneys placed, link them together, click on the very top chimney layer and merge down.  Do not let the chimney base layer get merged because we still have to do one for the mill and there will be merchant shops and smithies and stuff.  

106. We could easily just make a brush of a house with a chimney attached but the layer styles will affect the chimney as well...not to mention that as a brush the white parts of the brush will end up being clear once painted in, thus showing grass through the roof.  The best thing to do is draw one house (complete with layer styles) and draw one chimney (with layer styles), merge them together then make duplicates of this layer (which should be named “house base”).  You can then make as many duplicates as you need, move, rotate, etc.  I always like to keep an extra chimney base as a separate layer, though, so that I can put chimneys on my other buildings.  

107. CHURCH

108. I do the church just like it was a big house with a different color overlay.

109. INDUSTRY

110. What I mean by industry are places like the smithy, carpenter, shield-maker, etc.  These are places where work is done.  Again we'll do the line, noise, blur, color overlay, and gradient thing.  There is one caveat, though, the layer styles have to be rasterized or else the gradient overlay will get messed up, see step 93.  These buildings are usually bigger than the domiciles and usually have wings attached so keep that in mind when drawing your line.  In order to make wings we'll use the Rectangular Marquee tool again. Drag out a small selection that looks like it will be a good size for a wing and then rotate it 90 degrees counter-clockwise (if your sun is in the top left then rotate it 90 degrees clockwise).  After you rotate a chunk do not join it up to the rest of the building...if you do you will mess up the roof line.  So in order to prevent that you have to erase a right triangle (basically a square cut in half from bottom right to top left or bottom left to top right) out of one of the ends so that the roof line meets properly, this is called a mitre (not to be confused with the big hat the pope wears).  This is how woodworkers do the wood trim in your house.  This works for wings attached to the end of a building but not for something in the middle of a building...what we have to do for those is to erase two chunks (one in each corner) that forms something like a child's house drawing with 5 sides (2 sides for the roof, 2 sides for the walls and 1 side for the bottom).  Pay attention to the sun location as well, mine is in the bottom right so my roof lines will always be darker on the top and left...if yours is in the top left then your roofs will always be darker on the right and bottom.

111. Once you have one nice looking building done, then drag out a selection around it and move it into place and rotate to fit the angle of the street.  Continue chopping up the line on this layer and making buildings until you are happy, when done erase the unused line.  If you need more then do another line.  Don't forget to put those chimneys in...especially for the smithy.

112. INN

113. You should know where I'm heading with this...line, noise, blur, merge, color, gradient, rasterize.  Change the color overlay to red, or orange, or green, or something.  Make sure that you put in some type of barn for the horses of the travelers as well as some type of large open ground so that the horses and wagons can maneuver around and put in a lot of chimneys.  

114. At this point I'll also go back and flesh in the roads some more.

115. WELLS

116. I always put in some wells to give it a more authentic feel, even with a river right there...if the village is under a siege then they won't be able to go to the river.  These are pretty simple compared to what we have been doing.  Grab the Pencil tool, use a hard round tip and make a dot.  Add a blue color overlay, a 2-pixel outside black stroke, and an inner glow of something gray (set the choke at 100 and the size around 2 or 3).  

117. FENCES

118. Human nature being what it is we always like to put up separations between us.  I use the 1 pixel hard round and draw some lines.  You can also set the spacing at 200% to emphasize the posts rather than the rails (if your scale is something like 1 pixel = 3 inches then you can do both posts and rails).  Give it a brown color overlay and the 2 pixel black outside stroke.  

119. HEDGES

120. Wealthier people get hedges instead of fences.  Grab the Pencil tool, pick the 5 pixel hard round tip.  On the Brush Editor, set the spacing at 50%, scatter at 100-200%, roundness jitter and size jitter can be anything that you want.  Draw in some lines, keep your lines straight with the shift key (or for point to point angle lines click, then hold down shift and click somewhere else).  Add a layer style of color overlay of green, black outer stroke, small drop shadow, and maybe a pattern overlay if you like and a small bevel to make it look rounded on top.

121. MARKETS

122. You can this part three ways, one easy and two more involved.  The easy way is to just ctrl+click on the huts layer, create a new layer, fill it with black (or any color for that matter), set the fill to zero, then apply a very colorful pattern overlay, mess around with the scale and blend mode to get something that you like then deselect.  Of course this will get the chimneys as well so you might want to go in and erase those areas.  If your chimneys are on a separate layer then put the chimney layer above this.

123. The second way is more for making market stalls.  Plop down a bunch of squares in a line (say like a 10 pixel hard square tip pencil and set the spacing to 300 or more).  Put a brown color overlay on it and a grayscale pattern to break it up then add a black to white gradient (going from top to bottom) set to overlay then rasterize, move and rotate each square into place.  

124. The third way is more for fairgrounds tents and pavilions.  You can use either square or round tips but for the round tips make sure that the spacing is set to 1%.  Create a brand new image, File > New.  Make the image size 2 pixels wide and 1 pixel high.  Grab the Zoom tool and zoom in all the way to 1600%. Grab the pencil tool with a 1 pixel tip.  Place one black square and one white square side by side.  Click on Edit > Define Pattern.  Click on Edit > Rotate Canvas = 90 cw and then again define a pattern.  Save this image if you like (I didn't bother) and go back to our village.  Fill the layer with a layer style of pattern overlay using one of the two patterns we just created.  We now have some striped pavilions.  Add a color overlay and set the blend mode to either lighten or darken, depending on your color.  Add an inner bevel chisel soft and then you can start moving and rotating the tents into place.  If you have round tents then it gets a lot trickier.  Remove the pattern overlay and add a gradient overlay.  The gradient is tricky to make if you're unfamiliar with this.  Click on the gradient and you will have the black to white gradient to edit.  Change the white slider along the bottom to black.  Along the top change the right slider to zero opacity.  Click just above the gradient and add more zero opacity sliders at 10, 20, 30, etc.  Click on the black slideralong the top (this is the 100 opacity slider).  Now click again somewhere else and another 100% opacity slider appears.  Drag this slider to the 10 mark and make sure the the resulting gradient is solid black between 0 and 10.  Click again to add another 100% opacity slider at 20 but this time make sure that the space between 10 and 20 is transparent.  Click again to add another slider at 30 and make sure that the space between 20 and 30 is solid black.  The trick here is to not click on 10 or 20 or 30 but at like 15, 25, or 35 and then drag the slider into place at 10 or 20 or 30.  Once you have the alternating black and clear gradient you can save it (click on “new”) then click OK.  Now change the style to angle instead of linear and voila, your stripes run towards the middle instead of up/down or right/left.  Adding an inner bevel chisel soft really helps a round tent.   Lastly, add the 2 pixel black outer stroke.

125. Market stalls are usually placed near a gate or around the town square. Fairground tents are always outside of the walls except in big cities that have a permanent fairground.   

126. MILITARY

127. I always want to have some military buildings, barracks at minimum.  The barracks needs a training yard too.  Making this building is very easy, more squares and rectangles then copy the layer style from the castle.  If you want to have an archery range and stables and other things in separate places then they need big yards too.  To save space I put my archery range in the back of the bowyer, the armoury also gets a nice big yard in case of emergencies and the peasants have to undergo some training.

128. PROOFREADING

129. At this point it's a good idea to pull back and look at things more critically. What I'm not liking are the bight yellow spots on the high ground.  I know exactly what I'm going to do to fix this...some more mud grass.  Create a new layer and immediately add a pattern overlay of mud grass.  Nothing happens.  Well that's because I have to put some pixels on the layer.  Grab the Brush tool and the big ole airbrush soft round 300 and lower the flow to around 10%.  Airbrush over the top of any ugly spots and the pattern starts to become visible.  By keeping the flow low the pattern becomes gradual and not instant and lets some of the underlying terrain peep through.  I'm just going for a minor edit here, nothing major.  Set the fill of the layer to zero (to remove the color of our paint) and mess around with the blend mode of the pattern overlay if you like (I did not).   

130. FIELDS

131. Alright, we're getting close to the end now but we've still got some difficult work to do.  I don't want a lot of fields here for a small frontier village; most of their food will come from livestock and hunting and the fields will serve to grow vegetables and some wheat.  So I go back to the hedges layer and grab that same pencil tip and settings.  I draw out some hedges to form some rough squares.  This next part can take a while but it has to be done.  Remember how we created a pattern back in step 117?  Well, we're going to do that again but this time were going to make a bigger pattern.  Make this new image 20 pixels wide by 10 high.  Put in a black line that covers half of the image and a white line that covers the other half.  Then define the pattern and scrap this image.  

132. Back in our village create a new layer and draw out a nice big blobby shape but be sure that it does not cover up any area where we want our fields.  Fill the shape in if you haven't yet done so and then apply a pattern overlay of the pattern we just created.  Rasterize the layer (new layer, link, move under, click on top layer, merge down).  Grab the Rectangular Marquee tool and drag out a selection large enough to cover one of the field squares.  Grab the move tool and move this selection into place and then rotate it to any angle that you want (I usually go either perpendicular or parallel with the road).  Deselect and then grab the Eraser tool and erase the bits sticking out beyond the hedge line.  Drag out a new selection to cover another square.  This is the frustrating part...Edit > Cut then Edit > Paste to put this selection on a new layer.  Move and rotate to fit then erase the sticky-outy bits and deselect and merge down..  Keep doing this until you get all of your fields covered with stripes.  If you need more stripes then create a new layer, pattern overlay, rasterize.  When done erase the unused blob.

133. Filter > Blur > Gaussian Blur = 2 pixels or less...this softens the edges between our black and white lines.  Set the layer's blend mode to soft light.  Now our fields look like fields.  If you have some unruly terrain underneath that looks weird then create a new layer underneath the fields layer (hold down the ctrl key then click on the “create new layer” icon on the layer stack.  Grab the Eye Dropper tool and pick a green from somewhere close by.  Switch to the Brush tool and use that big airbrush again and paint in some green to cover up those unruly bits.

134. Click back on the fields layer and create a new layer and rename it to “Fields adjust”.  Change the foreground color to something green, I went with hex code 506E32 (RGB 80, 110, 50).  Change the background color to something tan, I went with hex code 9A814E (RGB 154, 129, 78).  On the layer stack, ctrl+click on the fields layer.  Filter > Render > Clouds.  Reduce the layer's opacity to 50% and add an inner glow of black set to overlay at 50% opacity, size is 100.  

135. FORESTS

136. Now for the piece de resistance...the forests.  This part is purely up to you to play around with but go through my steps at least once to learn a few things first before starting out on your own.

137. Create a new layer and reset the colors by pressing the D key.  Rename the layer to “Forest”.  Filter > Render > Clouds.  Image > Adjustments > Brightness/Contrast = set the contrast all the way up to 100 and then reduce the brightness to something that you like...what we're aiming for here are random shapes that resemble cow spots.  Filter > Pixelate > Crystallize = 12.  Repeat this but at 6 and then again at 3.  Reset the contrast (Image > Adjustments > Brightness/Contrast) all the way up again.  Filter > Distort > Glass = just leave it on the defaults for now, play with it later.  Filter > Brush Strokes > Spatter = leave it on the defaults.  Select > Color Range = black with a fuzziness of 200.  Hit the delete key then deselect.  This is going to be our base for the forests so you can now go in with an eraser and erase in places where the forests cover up roads, buildings, river etc etc etc.  Also erase in places where there are long strings...we want clumps.  

138. Now we apply the layer styles and there are a lot of them:  first the ubiquitous 2 pixel outside black stroke; pattern overlay of molecular (photoshop default); color overlay of green hex code 465A1E (RGB 70, 90, 30); inner shadow of brown hex code 5A461E (RGB 90, 70, 30) set to multiply, angle -45, distance 5 and size 5; drop shadow of black set to multiply at 67% opacity, angle -45, distance is 20, spread is 25, size is 5; inner bevel of smooth, size 51, angle -45, altitude 30, highlight mode is a mustard hex code C5C15F (RGB 197, 193, 95) set to soft light at 75% opacity, shadow mode of brown hex code 5A461E (RGB 90, 70, 30) set to multiply at 75% opacity; and lastly a texture of something called bamboo-forest-tile-2 (its in the zip file)with a scale of 25%.  

139. Create a new layer and rename it to “Forest adjust”.  On the layer stack ctrl+click on the forest layer.  Change the colors to the same two colors that we did in the fields adjust layer in step 127.  Filter > Render > Clouds and set this layer's blend mode to color.

140. Because I want to have some orchards I duplicate the forest layer.  I erase all of the places where I don't want orchards.  The best way to do this is to hide the Forest layer before erasing.  Once I have my orchards in place I add in a new layer style of inner glow of something dark red hex code 5A1E32 (RGB 90, 30, 50) set to dissolve at 20% opacity (this produces a bunch of little red dots that will be my apples), set the choke at 100 and size at 250.  Ctrl+click on this layer in the layer stack and then click on the Forest layer to unhide it.  Hit the delete key then deselect.  This erases trees that are underneath the orchards and so we avoid overlapping the layer styles.  

141. Now I go back to the roads layer and flesh those out some more.

142. I'm going to put a watchtower on another hill somewhere.  Pencil tool, 10 pixel square, duplicate, ctrl+click, noise, motion blur, merge down, color and gradient overlays add the 2 pixel black outside stroke.  Because this is a tower it won't get a drop shadow.  Instead we have to fake a real shadow.  Ctrl+click on the tower layer and then create a new layer then fill it with black and deselect. Click on the Move tool.  On the keyboard we hit the up arrow key 1 time and then the left arrow key one time.  Duplicate this layer and move up and left again. Repeat this process until you get a shadow long enough to make you tower look tall.  Once you are happy, link these layers together and merge down.   Filter > Blur > Gaussian Blur = 2 or less pixels.  Reduce opacity to 50% and move this layer beneath the tower layer.

143. At this point I go back and check everything to make sure that the proper layers have the 2 pixel outside black stroke.  

144. Create a new layer and fill it with white.  Set the layer's blend mode to soft light and reduce the opacity to suit you.  

145. Lastly, we have to put in a scale, a compass, some labels, and a key.  I'm not going to cover that as by now you should know how to add these things by just using the techniques that I have covered.  

146. If you want some fancy images like a knight or a dragon then you can add these now on the top.

