
 

Using GIMP to Create an Artistic Regional RPG Map 
A tutorial by “RobA” for the Cartographer’s Guild (www.cartographersguild.com). 

Part 3 

Post 14: Cities 

At this point, you can spend some time playing with colours, saturation, different 

overlays, etc. to get the land looking the way you want.  Once all that is time, it is time to 

start detailing the non-terrain elements of the map.  If you have an idea where cities and 

roads are to be located that is great.  If not, here are a few suggestions: 

- All settlements need water - fresh water for drinking and agriculture. 

- Communities usually have a reason/industry for existing in the first place – 

farming, mining, shipping, commerce, defence etc.  This purpose is often tied to 

natural resources in the area. 

- Accessibility is important for communities to interact with the world, and people 

will take the easiest path possible, not the shortest path.  Water is one of the 

easiest ways to travel. 

 

Once you have a mental idea of where you want settlements and roads, start adding them.  

I have found the simplest way to make cities is using dingbat fonts.  The one installed on 

every windows machine is called “wingdings”.  Here is the character map for wingdings 

generated by a free Windows font manager called “The Font Thing”.  (You can get the 

link by searching in the forums.): 

 
 



As you can see, there are some nice symbols for mapping here, depending on your map 

style.  Using a font manager will let you find these easier.  For this tutorial, I will use 

some similar characters to indicate settlements; I will use the symbol that looks like a 

ship’s wheel (“]”)to indicate ports, the little square cloverleaf (“z”) for walled 

settlements, and the simple dot (“l”) for all others. 

 

Create a new transparent layer called “Towns”.  When using GIMP’s text tool, it creates 

text on new layers above the currently selected layer, but we will be merging all of them 

down to the “Towns” layer.  Select the Towns Layer, and click on the text tool.  Pick the 

font Wingdings. You can leave the colour the default (black) or pick a different colour 

now.  Click in the general area you want a town marker: 

 
 

You can change the text size, alignment, spacing and such at this time.  Notice the new 

text layer created in the layers dialog.  Selecting the Move tool and toggling “Move the 

Active Layer” will allow fine positioning of the icon.  This process can be repeated with 

as many icons desired. 

Note: I have not found a way to get non-keyboard symbols into GIMP text.  In other 

Windows applications you can hold the alt key and type the keycode (like ALT+177 to 

get the crosshair dingbat).  Cutting and pasting from another application into the GIMP 

text dialog does produce non-keyboard fonts, but not what you would expect. 

Once this is done, all the icons will sit on their own layers.  (I used a smaller size for the 

solid dots as they looked too big at 22px): 



 
 

Now merge all the text layers down into the town layer.  This can be done one at a time 

right clicking the layer and selecting “Merge Down” or by turning off all the other layers 

and selecting “Merge Visible Layers”.  (I added a keyboard shortcut via File->Keyboard 

Shortcuts to make Alt-m merge down to speed up this action.)   You should end up with 

all the text layers gone, and just the “Town” layer left. 

 

The colour can be changes very simply at this time by checking the “Lock Alpha 

Channel” checkbox.  You can then just drag colours (or patterns, or paint with tools) 

from the Palette Dialog, and all the transparent areas will remain transparent! 



 
 

Create a new layer below Towns called “Towns Outline”.  This layer will be used to help 

the town icons stand out.  Right click and Alpha to Selection on the Towns layer.  

Enlarge the selection by 2 px or so (Selection->Grow) and optionally soften the selection 

(Select->Feather).  I used 5 px on the feather.  Now with the Town Outline layer active, 

drag black (or a contrasting colour to the town icons) to the screen.  Lock the 

transparency. 

 

With both layers having transparency locked, you can drag different colours, or play with 

the colour adjustments (hue, saturation, lightness) and layer blending modes.  Here I 

ended up with the icons using the “Roofs 3” colour and the outline the “Roads” colour.   



 
White on black (or vice versa) also work well if set to overlay mode. 

Post 15: Roads 

Now that you have some civilization, they need to get around.  A few things to remember 

are that people will travel the easiest way possible, even if it is longer.  That means that 

one thing that roads are not is straight (at least in a pre-industrial world!).  Even so, roads 

should be smooth.  Trying to draw roads by hand is extremely difficult (especially if you 

do not have a tablet).  My preference is to use paths, and stroke them as desired.   

In truth, I prefer Inkscape for editing paths as I find it easier, and it is very trivial to have 

a workflow that integrates GIMP and Inkscape.  However, this tutorial said using GIMP, 

so that’s what we’ll use. 

ASIDE TIP:  To bring an Inkscape SVG into GIMP as paths, right click on the little 

triangle in the Path palette to bring up the Path Menu option, then go to Import Path. 



 
Just follow the dialog.  There are two options at the bottom.  Merge Imported Paths will 

cause all the vectors to be imported as one path.  Scale Imported Paths to fit Layer will 

scale op the extents of the SVG image to fit your gimp image size.  If not merged, each 

path will come from Inkscape as a separate path, so combine (not group) any paths you 

want to be imported as a single element. 

Once you have decided where your roads go, start drawing them with the path tool.  Click 

on the path tool (pen icon) and to draw curves, uncheck the Polygonal option.   

 



Click on the drawing where you want a path to start (a town) and drag in the direction 

you want it to go.  Then click the next node of the path and drag to set the curve again.  

This can be continued as long as desires.  The edit mode can be used to move and change 

the handles of notes.  It is also worth mentioning that paths can be edited while zoomed 

in.  This makes it easy to accurately set where they are: 

 

 
 

Using the path tool will automatically create a new path in the image.  Paths are not really 

visible on an image, but can be turned into selection or stroked with any of the tools.  

Paths can be made visible by clicking on the eyeball icon (just like layers).   

Paths can even extend beyond the drawing edge. 



 
 

Once you have all the paths that represent your roads (or all the roads of a particular 

style) merge them into one path my making them (and only them) visible in the path 

dialog and right clicking Merge Visible Paths.  Then rename this path to “Roads”. 

 



Post 16: Roads (continued) 

Once the paths for the roads are defined (either using the path tool in GIMP or imported 

from Inkscape) it is time to actual render them onto the map.  There are two main styles 

for roads – single stroke, and over-stroked.  Single stroked roads look like a line (dashed 

or solid).   Over-stroked consist of multiple strokes layered over one another.  For 

example, a wide dark stroke with a light narrow stroke on top will look like a light road 

outlined in dark.  The type of stokes used will be depend on the style you develop, and 

you might want to use several, along with a legend, to indicate what they represent. 

Here we will make a road similar to that of the ones I used in my Niagara map. 

 

Create a new, transparent layer below the town layers, called “Road1”.  Select white as a 

colour, and click Edit->Stroke Path (since there is only one path, it is selected as the 

current path).  Choose a width that goes with your map scale (I used 3 px) and pick a 

solid line with curved end caps.  Click Stroke. (I brought the dialog up again after 

stroking to show the options used). 

 

 
 

Change the drawing colour to black and bring up the stroke dialog again.  This time, use 

1.5 px, and a custom pattern.  Draw the dash pattern you want to use.  I made it short 

dashes. 



 
Change the layer blend mode to Overlay to get a nice road that blends in well.  

Alternately, different colours could have been chosen up front for the roads if you wanted 

specific colours.  I want them a bit darker, so duplicate the Road1 layer. 

 



 

This looks nice now, but the roads are hard to see in the forest, so lets fix that.  (And here 

is where the power of paths really comes into play.) 

Select the “Forest Bumps” layer, ensuring the mask is selected for editing.  Pick the 

paintbrush tool, with black paint, and a fuzzy brush slightly wider than the road. 

Now again, stoke the path (Edit->Stroke Path) but this time select “Stroke with a paint 

Tool” and make sure paintbrush is selected.   

This will paint a black line on the bump layer mask to make the road more visible.  You 

could do the same thing to the colour layers as well to define it more. 

Alternately you could stroke with the erase tool to erase areas along a path, or the smudge 

tool, or anything! 

 

 
 

Finally, as an optional step, to make the roads more jittery, I went back and applied a 

small (3px) displacement map to them (Filters->Map->Displace) selecting one of the 

noise layers in the drawing.  This just makes the roads less smooth, and a bit more hand-

drawn (though it does look better to do this on a single stroke map). 



 

Post 17: Labels 

It is now time to start labelling the map.  Most of the horizontal text will be made using 

the text tool just like the city icons were done. So I won’t provide the detail here.  Just 

merge all the text down to one layer when happy with its look, and apply an outline glow 

to separate it from the background.  I am going to use the same colours as the cities 

themselves for most labels. 

One thing to remember is that more is not better when it comes to font text.  If there is 

more than four different fonts then something should be reconsidered.  I would suggest 

one font for most labels, optionally a different, possibly more ornate font for a map title, 

and a clear small font for labelling rivers, roads, etc. 

Colour in labels can be useful as well, keeping cities in one, territories in another, etc can 

help make a complex map easier to read. 

I am using a font called Chaucer Ultra-Light for most of my labels.  I also duplicated the 

text layer to make it a bit heavier, and reduced the opacity of the outline to 50%.  To 

make things fit better, I also used different font sizes corresponding to the importance of 

the city. (Hedge and Il-Lac are both in a smaller font.) 



 
 

Labelling terrain requires a slightly different approach, as terrain labels often follow 

terrain (for example, labels follow mountain ranges and rivers).  For those labels that are 

horizontal, just do them the same way as the city labels.  For others, here is the way to do 

them using GIMP 2.4, which now supports a “Text along Path” function.   

This does not actually bend the text to a path.  Instead, it creates a new path outlining the 

text that is bent along the previously active path.  As an example, lets add a label to the 

mountains. 

Select the path tool (just like when making roads) and create a new path along the line 

where the text should go (I have changed to the path dialog as well to show the new 

path): 

 
 



Now pick the text tool, and click in the middle of the screen. You can set the font and 

size, but there is no point setting the colours.  Set the alignment to centered, and type the 

desired text.   

Click on the “Text along Path” button.  This will create a new path outlining your text, 

bent along the first path drawn.  If you need to change the text (font, style, spacing) or the 

path, undo (ctrl-z) and make the changes in the text or path and redo the whole “Text 

along Path” process. 

Depending on how bendy the path is, the letter spacing might have to be changed to 

prevent the letters from being either to mashed up or too spread out. 

 
Now in the path dialog, click on “Path to selection” (or right click->Path to Selection).  In 

the Layers dialog, create a new Transparent layer called “Labels” (or what ever you want 

to call it) and fill it with your desired colour.  Here I chose to keep the colours the same 

as the city labels, but flipped around (light text with a dark outline).  Remember you can 

fill a selection simply by dragging from the colour palette. 

 

GIMP Note: ctrl-t will toggle displaying the “marching ants” outline around 

selections.  This is handy to see the results of a fill. 
 

 



 
 

Now create the outline layer “Labels Outline” below this, and (as for the previous text) 

grow the selection and feather the selection.  Now fill on this new layer with the desired 

colour: 

 
 



You can see that the text layer is still there but is not necessary.  It is however handy to 

just reuse this text layer to create any additional labels you want.  I tend to put all the 

labels on one layer, so after getting the text selection, make sure you select the proper 

layer to fill on. 

Finally, all of the paths used for lining up the text can be deleted (if desired) or keep them 

in case you need to redo the text later. 

GIMP Note: The transform tools (rotate, move, scale, skew and flip) can all be used 

on paths as well as layers and selections.  This means that if the text isn’t exactly 

where you want it after putting it on a path, you can move it, rotate it, etc. 

 

Here is the map after adding a number of titles and labels: 

 

 
 

 

 

 

 

 

 


