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PHOTOSHOP: MAP MAKING : CREATING TEXTURE FOR A FICTIONAL MAP
SKILL LEVEL :  INTERMEDIATE

ABOUT: CONCENTRATES ON APPLYING A RELIEF TEXTURE TO THE MAP CREATED IN PREVIOUS TUTORIALS, COVERING 
THE USE OF GREYSCALE HEIGHT INFORMATION. IT ASSUMES YOU HAVE AT LEAST LOOKED OVER THE OTHER TUTORIALS 
OR HAVE SOME KNOWLEDGE OF PHOTOSHOP AND ALPHA MAPS.

If you're not a complete beginner, or want to skim through all the detail explanation, I've highlighted the key 
parts, so just look out for those.

THE FINAL RESULT:

This is the end result. creating a relief map to give a top down 3D look. There are various options and this 
tutorial will cover the thee shown above
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First, something worth covering: what is a height map?

It's a gray scale image that uses tonal values from white to black to determine the height of that image, or an 
image the height map will be used with. For all height maps the highest point is white and the lowest black. It 
can be used in Photoshop, but also in 3D applications like 3Ds Max or Maya [ among others ] used as a 
'bump map' or 'height map' and also a 'displacement map'. 

Here's some very basic illustrations. All these use the first gray scale image. First some test in Photoshop 
and the two versions in perspective are in 3Dmax rendered to show the polygon density. 'White is High' 

Now what you can do in Photoshop, using Filters. We will use Lighting Effects and Emboss in this tutorial, 
but it's encouraged that you try the others and play with the settings as you might like the results and it can 
effect how your map turns out - you might discover a new technique! If this is all new to you, then I suggest 
try playing around and experimenting with various settings
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Note:

Height maps are also used to create 'normal maps' which are used to define detail on a low polygon model 
for use in video games. I won't go into detail in this tutorial, but you can find a definition here and a tutorial 
here . It's used to large effect on most new games like Gears of War , Mass Effect, Army of Two and Medal of 
Honour, to name a few, who all use just one application Unreal Engine - but there are may others. 

You can get a Photoshop plugin to help create a normal map here which uses grey scale information - a 
height map. [ though it must be said that not all normal maps are created from a grey scale image, some are 
created from high polygon models ]

OK! that's the basics over with - lets move on...

1.0: I'm starting with the result from the previous tutorial. Get your coloured map - you can have anything you 
like, as long as you have the alpha map you made it with and it's in the Alpha1 Channel as it will be needed 
to use as a mask. 

Also put one in your Layers , but Invert [ Ctrl+I ] it so the land is white and the sea is black [ you could have 
your alpha like this it doesn't matter, I used black for the land mass to make it easier to read as a silhouette - 
it's a personal choice - but height maps must conform to white being high, Black is low ]

1.1: Drag the Inverted Alpha map - which is now a height map - to a new layer. then select the top of the two 

1.2: Go Filter > Artistic > Poster edges. Whack all the settings up as high as they will go > OK

1.3: Create a new duplicate of that one, by dragging the layer to the new Layer icon. Filter > Brush Strokes > 
Accented Edges. put the Thickness high, but the others low until you get something like this..
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1.4: Edit the new layer to remove any unwanted black lines around the edge of your art work. You don't need 
to accurate. Then Filter > Blur > Gaussian Blur. I did 7.5 . Drop the Opacity Down to about 65%

1.5: Jump to the Poster Edges layer you did in 1.2 . Blur it a bit You want steps of blurriness I did about 5 - 
we are developing the height map. Drop the Opacity to 50%. You should now have 3 layers that show the 
rivers are at a lower height than the surrounding land - Something like this...
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1.6: Create a new Layer and fill it white.

1.7: Select the new Layer and go to Filter > Render > Difference Clouds . Then Filter > Difference Clouds [ at 
the top you'll see it's a repeat Filter option ] or Ctrl+F . Do that about 30 times. You should end up with 
something like this.. 

1.8: Go back to your Layer you created in 1.7 make sure it's above the other layers. Set the Layer blend type 
to Difference. Your rivers should come through. 

2.0: Duplicate the original height map [ 1.0 - that the one where the land is white and the sea black ] and 
place it above all the other layers. set the layer blend to “Color Burn”. The details of your rivers should come 
through, and it'll mask out the sea to black...
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Now our height map is starting to show mountains and valleys. White high, Black low.

2.1: [ Optional ] Create a new layer. Get a fall off / soft brush and black as your colour and set the new layer 
Opacity to 50%. paint over areas you like to have lower ground. 

You can change the opacity of your layer, to suit the lowest and then adjust the opacity of your brush to 
gradually work up to higher altitudes. You can also use the Dodge and burn tools on the height map, but try 
not to bleach it out or go completely black. its easy to do, that's why I do it this way as it give me more control 
and easier to change it goes wrong.
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2.2: Select all. the Ctrl+Shift+C then Ctrl+V . You should have all your layers merged together on a new 
layer.

2.3: Copy it and then add it to your Alpha Channel as Alpha 2

2.4: Create a new Layer in your Layers Palette above all the other ones. Fill it white.

2.5: Go Filter > render > Lighting Effects. This will open a box for your to Edit. Make sure You have your 
Alpha 2 layer selected and 'white is high' checked. You want Directional Lighting, but everything else you can 
play about with see what happens. You're looking for an over al lighting, not harsh. so try and keep the 
highlights down. Also try and keep it matte , not shiny - here were my settings, but its really a unique setting 
for your work...

2.6: Duplicate your Original colour layer and put it under the render you just did. Set the blend to Normal and 
give it about 85% Opacity. Set the layer blend of the render to Overlay [ this is not set in stone - try moving 
them about and see what various blend modes do - you might find something better to your liking ]

2.7: [ Optional ] Duplicate Colour layer again. then duplicate the height map layer, and run it through the 
Filter > Stylize > Emboss . Set the light direction to match your render lighting effects.
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2.8: When that's done, turn the Blend of the Emboss to Overlay - Make sure your colour map's blending 
mode is Normal and at 100% Opacity. 
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2.9: Duplicate the height map and place it at the top layer. Set the blending mode to Hard Light. Opacity 
about 60% It will lighten the mountain tops and darken the valleys. 

You should now have two variations with one mountainous and one a lot less bumpy. If one is harder lit than 
the other try selecting the layer that the relief layer and change the Image > Adjust > Levels so it looks better 
for you. Here's the two I have...

You could stop here if you wanted. You can play with the levels and adjust stuff. The reason I've got you to 
do two is so you could see different way of doing this, but also to do more from here on in...In many ways, 
this is only the beginning!

3.0: Flatten , or create a new file so these two has one above the other. Then, using your eraser delete away 
so you bring through the flatter areas of your land. 
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3.1: I also made sure my height map was on the top layer - but not flattered with them. I also brought across 
the original alpha mask and put it in the alpha channels. then, with the sea area selected, cut and past above 
all layers to brighten it up.

3.2: As you can see (below) the edges of the map has some artefacts which make look too bright and in 
some places some nasty sharp contrasts. This is because my original colour map was finished with it's style. 
If I were to create a colour map that was going to end up as a relief, then I'll not do that so much. So I 
stroked the inside edge of the coast with black [ using the alpha map ] an then blurred it . Now the water is 
too bright, but I'll sort something out later. 
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3.3: We could finish this now. But there's even more! 

There is one thing is missing that would really give it even more realism. More realistic errosion from the 
mountains to the sea would help out a lot. I've tried to do this in photoshop, but not discovered a decent 
method. The stuff above is adequate, but we can improve on it, it's a personal choice.

Luckily, there is a free program out there which is written that does just the job! it's called Wilbur . Big thanks 
to Joe Slayton for making this great tool available and to friends over at the Cartographer's Guild for pointing 
this out to me. Download the 32bit version and install it. There is an online tutorial for just what I want to do. 
Check it out before continuing. You'll need it open because I use the tutorial to create the next part of the 
map.

First though, I did some tests. Here are the results...
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3.4: So I will export the height map I made to Wilbur, First though, it must be a GrayScale Image to import. 
So either flatten your PSD file to the height map, or cut and paste it into a new document. Go Image > Mode 
> GrayScale and OK to discarding color information. 

3.5: Open up Wilbur and then open up your GrayScale image. It'll turn the green to white colours you see 
here. Using the Wilbur Tutorial, apply the settings to your map. Here's my various stages of this. I adapted 
the tutorial settings to suit my map...
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3.6: Apply this render to your layers and select multiply (the render may need to be rotated)

4.0: Next, We need to bring the sea back. if you have something like mine, then you'll have big veins of rivers 
there. I'll be good to keep some of this as it'll show the river channels into the sea. You don't have to of 
course. it's a personal taste. 

Jump to your colour layer . Then go to your original mask channel Alpha 1 and select it so you get the sea 
area. Now in the layers of your original colour, cut and paste the sea to a new layer. You might need to play 
with the saturation and levels is it's too bright.

4.1: I then Duplicated the height map and put it above everything. Layer Blending mode to Luminosity with 
an Opacity of 20% . 

I needed to stroke the coast line again as I did in step 2.8 - again, if you create your colour map with this 
result in mind, you probably wont need to do that. Plus, as you can see in my screen above, the lakes in the 
top left were lighter than the rest, so I needed to correct that too.

4.2: Finally, I but the sea on the top layer again, Merged it all, tweaked through levels and saturation. That's it 
done! You can keep playing with it and try filters on top like Paint Daubs for example, or Unsharpen tool.
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It must be said that there are multiple results from this method, some could be left out or different Layer 
blending modes used. Totally up to you and you can explore to make it your style.

The key is the height map. If this map had a purpose I would probably taken more care of the height map to 
create plains and flat lands. Also I would work into the the mouths of the rivers more so they are not so black. 
I probably when a bit overkill with the Wilbur render.

You could blend various versions of your height maps to create one master height map - it's all in your hands 
and I encourage you to try different things and see what you get. 
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Here are a couple of other maps done with more practising and taking this technique further...

You can see the full version and WIP steps here

You can see the full version and WIP steps here

Thanks for reading! Have fun!
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