
 

 F. THE CASTLE  

• Next we’ll add the castle.  Creating this is a short tutorial all in itself, but it’s very 

simple.  Basically, while I could let my imagination go wild, I instead “steal” 

castle floor plans from actual castles.  Why?  Mainly because I need some sort of 

inspiration to get my creative juices flowing; the end result almost never looks 

like the model, anyway.    

• Do a web image search under castle plan, floor plan, blueprint, or footprint.  Find 

one you like, then copy it into a new document in an “original” layer.   

• Note:  if you are creating a map for commercial endeavors be aware that while no 

one owns the rights to the layout of a castle, other people’s 

photographs/artwork/drawings are protected by copyright.  I am not a commercial 

artist, but thought I should drop that in FYI. 

• As my inspiration for Eneini’s stronghold I chose the 12
th

 century Wolvesey 

Castle, now in ruins in Winchester.  I especially like it because it’s so 

asymmetrical.  I found a nice, high-quality floor plan (plus some photos to boot!) 

so I pasted the footprint into a new Photoshop document as a “background” layer.  

As with the main document I made this too big (about 1000 px square) just in case 

I ever wanted to use it later for uses outside this particular map.   
 

• Next I created a “Walls” layer & traced the walls so 

I had a basic wall plan.  (You could also use the 

magic wand to pick the walls, play around with the 

selection settings, & fill it in with black, too.)  

 

•  During & after this I modified the original floor 

plan heavily;  this is no longer Wolvesey Castle, it 

is Eneini Castle! 

 

 

 

• Hide or eliminate the original “background” layer, so the castle you downloaded 

cannot be seen. (You could delete it, too.) 

• Below the “walls” layer, create layers for each “elevation” (or “height”) of the 

castle features, and color each a distinctive color.  While, of course, specifics for 

the castle are unimportant for my ginormous Eneini city map, I did give just a tad 

of thought to logical construction of a castle—just in case I ever needed to make a 

close-up map, etc.  If I were in a hurry I’d just do some quick sketches & call it 

good. 

• I usually use prime colors first [see left image] to make the layout easier to see, 

then I “replace color” to roof colors more in line with my map’s color scheme       

[ see right]: 

o walkways/platforms = grey 

o high tower roofs= lightish red 

o medium roofs =  rusty 

o lower roofs = brown 

o walkways = grey 



o ground level (courtyards) = blank   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

• Next, select the walkway layer & “fill” 

the grey with the stone pattern you made 

before we began the map.   

• Do the same for the black walls, making 

them stone 

• Image>Adjustments>Color/Balance the 

walls to make them stand out from the 

walkways.  (Again, this detail will almost 

entirely be lost in a large city map, but if 

I ever need/want to create a closer image 

of the castle…) 

 

• I also “played” with a few last-minute 

touches, such as roof lines, just for fun. 

 

 

 

• Now delete/hide the white background & select-copy-paste the castle into place 

on the city map on its own “castle” layer.  Play with size via 

Edit>Transform>Scale.   

 



 

G.  CITY & CASTLE WALLS 

• Now that the castle is in place I clearly know what level of detail I need for the 

walls.  In an earlier map I made of a smaller city, the castle & walls were much 

larger, so their details became important  (Below is a draft version of that map.) 

 



 
 

• Eneini, however, being a large city, requires much less detail.  Why so?  Well, not 

only will such fretwork such as stones be lost at the scale we’re working, but I’m 

gambling that I won’t ever want to blow up a detail of a wall section.  Therefore 

we can use a “quick & easy” method on the walls.    

 

• Click “on” the “walls sketch” layer at about 30% opacity so you can see through 

it.  Create a new “walls 1” layer on top, then use the polygon lasso tool to select 

the first wall “circle.” (In this case, the castle walls).  Do NOT draw the outside 

dimension of the walls, but their centerlines. 

• When the circle is complete (& even if you don’t need a circle, close the figure 

anyway & you can erase unneeded portions later), choose Select>Modify>Border 

& choose an appropriate width (for my large city, it was 6-8 pixels). 

• Now fill this layer with a darker gray 

• Finally, before deselecting your wall, choose Edit>Stroke & choose black, an 

appropriate width (eg, 1 pixel), & about a 50-75% opacity.  This will give the 

walls some definition. 



 
• Repeat this for all walls, erasing any sections you don’t need.  If you have many 

wall sections like I do in Eneini, you may wish to put each on its own layer. 

 

• You can delete the “Wall sketch” layer if you wish. (As well as the “town sketch” 

layer.) 

 

• As for towers & gatehouse features in the walls, I will again use the “quick & 

easy” method;  if I were drawing a smaller city where these features would be 

more noticeable, I’d spend much more time on them. 

• Create a new, “towers” layer above the walls layer to which you plan to add the 

feature. 

• In the Brush Tool pull-

down (or F5), switch to 

“basic brushes” (or 

“square brushes” if you 

plan to add square towers 

vs. round);  choose a brush 

with a hard edge, sized 

just a bit larger than the 

wall thickness.   

• “Stamp” down the towers. 

• When done, select the 

circles & Edit>Stroke 

them with a dark, 1 px. 

edge, 50% or so opacity. 

 

• At this time also draw in 

gatehouses & such (in 

wall-color grey, with dark 

grey highlights/features 



drawn on top).  I also like to line my bridges with “stone” color.  The layer does 

not really matter for these things, although you might just as well create another 

for them. 

 

• Inside the castle I’m also going to throw in a few buildings for stables, etc. & add 

some roads & such to fill it out.  (I also like the idea of the castle being on a sea 

cliff, so I’m adding more cliff definition now, too) 

 

• Finally, create groups in the layers palette for the castle & the city walls. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



H.  TREES, VEGEATATION, & FARM FIELDS 

• Inside your “land” set, create a new layer called “trees” 

• Using a solid color brush of any bright color (ex: white), draw on the places 

wherever you want patches of trees. 

• Click the paint bucket, choose “pattern” instead of “foreground,” click on the tree 

fill you created earlier, 

and make sure the 

“contiguous” box is 

unchecked.   

• Then click the bucked 

on any one spot of your 

coloring;  it should all 

become your tree 

pattern. 

• Now with the eraser set 

at about 80%, go around 

each batch of trees & 

fade the hard edges;  

you can even sculpt 

them a bit more if you 

wish.  [Alternatively, 

you may use the blur 

tool around the edges, 

too.] 

 

 

 

 

 

 

 

• You could also use the above process to add many types of trees, or to add other 

types of vegetation;  I think this works better for maps in closer detail for mine, so 

I won’t do it here. 

 

 

 

 

 

 

 

 

 

 

 

 



• If your map needs farm fields do it now.  Use the same process as with trees. 

 

• Since Eneini is set up for a coastal city on hilly, somewhat rocky terrain, I’m 

going to assume the outlying farm hamlets & villages mainly line the roads a little 

further inland than my map depicts, but I’ll throw a few in just for more color 

details to catch the eye.   

 

 
 

 

 

 

 

 

 

I.  FINAL CITY DETAILS 

• Now would be the time to decide if there are any final details you would like to 

add to the city.   

• Maybe throw in a few large stone buildings in the city proper?   

• A set of ruins outside the walls?   

• A large garden, lawn, or park somewhere?   

• Perhaps a stream or small pond?   

• What about an arena?   

• Some map makers also add docks sticking into the water,  which I am not sure is 

historically accurate, but can look nice.   

• Just remember:  for this style of map what is necessary is not intense detail, but 

mere touches of shape & color. 



 

J.  APPLYING EFFECTS 

• Now it’s finally time to apply some of the artistic filters for which we’ve been 

planning.  First make sure you have a saved backup copy of the entire map under 

a different name. 

 

SHADOWS:   

• Click on the “buildings” layer & then click layer style (it’s the little “F” in the 

circle at the bottom of the layers palette),  

• Choose “drop shadow” 

• Play with the settings as you see fit.  (Mine are Multiply, 70% opacity, 165 deg. 

angle, distance 5, spread 0, size 5, noise 0—although I play with everything by 

eye.    

• Do this same for the trees, walls, castle & towers layers. 

 

 

BUILDING PATTERN & DEPTH:   

• So the buildings don’t look too “clean” I apply a second layer style after drop 

shadows:  “pattern overlay.”  I choose the “metal landscape” layer that came 

standard with CS2 as the pattern,  Multiply, 20% opacity, scaled to 200%. 

• While in that same screen, choose “bevel & emboss” and under the “Texture” 

screen choose the standard “wrinkles” swatch, set to 200% scale, -100% 

depth;    

• And let’s apply one more layer style to the buildings:  “Bevel & Emboss.” 

Choose Emboss, chisel soft, with depth of 75%,  Direction “up”, size 7, soften 

3;  make sure that the angle below matches what you’ve been using in all the 

drop shadows so far, and that the highlight mode is color dodge at 25% 

opacity, and the shadow mode is color burn with 25% opacity.  (Remember:  

play with these to fit, too!) 

• When all’s done, you should have 3  pattern overlays on your buildings:  drop 

shadow, bevel & emboss, + pattern overlay 

 

 

 

LAND EFFECTS:   

• Give the “land” layer a layer style of “Bevel and Emboss” – “texture”;  I chose 

CS2’s molecular pattern (or, sometimes, the stone wall  fill I created earlier), set 

at 250% scale & 40% depth;  

• in the “Structure” give Inner Bevel, Smooth, depth of 50%,  Direction “up”, Size 

18 px, soften 8px;   

• I also downplayed the highlights & upped the shadows.   

• [Note that you can, if you wish, do this same procedure to the hill elevations, the 

“rock” layer, & even the water!] 

 

 

 



 

OVER LAND SHADOWS:   

• Remember that layer called “Overland Shadows” we created so long ago?  Now 

grab it & put it as the very top layer.   

• If it needs adjustment, go ahead and play with it!  Fill in more, make it darker, 

erase…whatever. 

 

 

 

 

• Here is what my completed map looks like after all these filters, patterns, and such.  

As you can see I have tweaked here & there with this & that.  You can also note 

that with only a few tweaks further this could perhaps itself serve as a serviceable 

city map! 

 

 



 

K.  POSTERIZING! 

• Save your map one last time—maybe even under a different file name.  Now on to 

my favorite step!! 

• Layer>Merge Visible 

• Filter>Artistic>Poster Edges, with setting to your taste (mine are Edge Thickness 

1, Edge Intensity 1, Posterization 4) 

 

 
 

• From here we have many options.  We could call it good & move on to 

labeling the map & such, or we could play with the appearance a bit more.  

We could even make it look drawn on parchment, wrinkled, etc. 

• First I am going to lighten my map a tad, plus add some “graining” to it, just 

for a softening effect.   



• I click on what is now my only layer (which I’m renaming “map”) and add a 

layer style of “Inner Glow”;   

• Under “Elements” click the “Center” radio button, & have the pull-down on 

softer, with choke & size at 0;  Under “Structure” have color dodge set, with 

opacity at about 10% & noise at 0%, and the color set to a pale yellow (not a 

gradient).  The “Quality” settings don’t seem to matter, so I set them to 0. 

• Under the Filter>Noise>Add Noise I play with the level to give it the look I 

want. 

 

 

 

L. TEXT / BORDER /  TITLE 

• Now we’ve come to the final step!  The labeling is fairly self-explanatory, 

although there are many ways to achieve it.  Because this is an artistic 

rendering of a map (vs. an attempt to capture authentic cartography or be 

photorealistic),  so text style choices are arbitrary.  I chose Charlemagne 

Standard, which I think is just a default package font.  Nothing special. 

• I added all the text in white, sometimes using the Path tool to allow words to 

follow rivers & such. 

 

• I used Image>Canvas Size to up the size of the canvass, & then created a 

lowest level called “border”;  I filled it with a solid color (although you could 

get fancy here, too, if you wish;  I don’t want it to detract from my map itself 

so I just added some noise.) 

 

• Add a title 

• Use the marquee tool to surround the map, then used Edit>Stroke to create the 

black map border. 

 

• Save the new file with all its texts, border, & title under a new name.  (Yes, 

again!) 

 

• Finally, hide the map layer, the border layer, & the title layer, & choose 

Layer>Merge Visible;  this allows the text to be fancified, vs. being merely 

text. 

• For all the text, add a new layer style “drop shadow” that fits your eye.   

 

• Okay, now do whatever final touches you wish, & you’re done!! 



 

 

I sincerely hope this tutorial helps you in some minor way.  If you have 

comments, suggestions, improvements, criticisms, or whatnot, send me an 

email at djembeck@invisalink.net. 

 

For more maps, check out my Westaven gaming group’s website at 

http://www.ormonds.net/rpg/westaven/index.php/Main_Page  or The 

Cartographers Guild at http://www.cartographersguild.com/ 

 

--“Pyrandon” (aka, Don) 



April 2007 
 

 

 

 


