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Xara Xtreme 4.0 is the latest version of a unique hybrid raster/vector 
application - touted to be the fastest graphics application in the world. Note, 
this is not a map making application, it is really something comparable to 
CorelDraw, Adobe Illustrator, with some light duty raster tools. Because my 
job requires more than just creating maps, and Xara Xtreme allows for web 
authoring, sign design, PDF document creation - its my preferred app. This 
PDF tutorial was created in Xara Xtreme 4.0

Xara Xtreme 4.0 is available as a 14 day free trial download, but costs about 
$89 as a shipped CD.

Download Xara Xtreme

Creating Winterscape Maps 
using Xara Xtreme 4.0
 
This tutorial will quickly teach you the techniques I use to creating photo 
realistic maps, like the one pictured below.



Once you’ve downloaded and installed Xara Xtreme, open the application: 
Below is the default Xara document. You will be required to make some 
adjustments to units, page size and grid, before you begin mapping.

The primary tools used in creating this map are: the Freehand Drawing Tool,  
Shape Editor Tool, the Color Fill Tool, the Transparency Tool, the Shadow Tool 
and the Bevel Tool, all of which are located on the left side of the screen.

You will need to change the scale and dimension of the default settings to 
meet your needs for your VT map.

Go to File/Page Options to open the
Options menu located in the top menu bar.

First click on the Units tab. The default
setting is Pixels. Change this to Inches.
(You can scale in pixels, but use inches for tutorial)

Next click on the Page tab. Select Custom
from the top preset, then 20in x 20in below
that. Note you must include “in” for inches,
otherwise, Xara will give you an error.

Freehand Drawing Tool
Shape Editor Tool

Color Fill Tool
Transparency Tool
Shadow Tool
Bevel Tool



Once your scale and dimensions are set, you’re ready to begin mapping.

The quality of the map is entirely dependant on the quality of the photo 
textures used. There are many sources for quality terrain textures. This 
tutorial uses images downloaded from cgtextures.com, however to make 
using this tutorial easier, I’ve already downloaded the images, and have a 
link here for you to download the specific images for this tutorial.

Download the 3 images linked on this page.

   Tip: once you import a given image file, delete it immediately. All images  
   imported into a Xara document is stored in the Image Gallery. At  
   anytime you can access copies of the
   image files. The Fill Tool menu also
   stores these files in the Bitmap menu.

Although when in mapping mode, you really do not want “Snap to Grid” 
function on especially when using the Freehand Drawing Tool, however, 
for creating rectangles to define the map background, I use “Snap to Grid” 
to line things up perfectly. Remember to set this to off, when doing Freehand 
mapping.

You can turn on Snap to Grid, under Windows/Snap to Grid in the File 
menu at the top of the screen.

With Snap to Grid on, I use the Rectangle Tool, on the left side menu to 
create a background. I use the entire 20 inch x 20 inch document area to 
place this square. By default you probably have Line Width set to .5 points, 
and Fill Color in Black. The image below is what is described above.



Every tool located on the left side tool menu, opens an Adjustments Menu 
for the selected tool. This is located just below the File Menu at the top of 
the screen.

Click on the Fill Tool (the tipping paint bucket). Notice the first drop down 
menu at the top left of the screen, with the current default setting Flat Fill.
Click on the dropdown arrow and select Bitmap.

Now the Adjustments menu changes to Bitmap Fill options. If you need to 
force the image into a repeating image, you set this in the next drop down 
menu. However for the first image, leave it in Single Tile mode.

Select the Rock texture from the
Bitmap Name dropdown menu.

Notice the entire black square is
now filled with the Rock texture fill.

You should notice an “L” shaped vertice
at the center of the image. This allows
you to rotate the fill image, move the
fill and rescale the fill to fit your needs.

By selected the end points, you can
now rotate the image fill.

By selecting the joining point of the vertice, you can move the fill within the 
square object.

You can easily rescale by left clicking, holding the mouse button and ragging
away from the center or towards the center to rescale larger or smaller.

If the image does not fill the entire object, you should scale it larger.

Optionally you could set the tile setting to Repeated Tile or Repeated 
Inverted to fill.

For this tutorial, you can leave the fill “as is” without rescaling or rotation. 

Now you will begin to use the Freehand Drawing Tool, on the leftside tool 
menu - its the “Pencil with the Drawn Line”.

Make sure “Snap to Grid” is turned off, under the Window menu, before you 
begin drawing - you really don’t want any constraints holding back what you 
are trying to draw.



Use the photo itself to guide where you want to place the snow. The texture 
of the rock shows high and low areas. Place the snow freehand object in the 
“low” areas.

Its important for you to know where
you start Freehand Drawing, as you
will want to connect the object closed
at the same point. A “+” appears when
the pointer is near the originating point.

Once the object is closed, you will notice
that the application automatically smooths
the lines into a nicely rounded shape. You
don’t want this!

Notice the slider tool in Drawing Menu,
below the File Menu at the top of the
screen. Slide this to the left to a setting of
“0 to 4”, to get more like what you created.

Select the object, click on the Fill Tool, then
select Bitmap from the Fill Tool Menu, and
select the first snow image from the Bitmap
Image Gallery dropdown.

You may notice a black outline. To remove
the outline, right click on the “cross hatch”
fill in the color menu at the bottom of the
screen. A menu opens, select “Clear Line
Color” and the outline disappears.

Its best to enhance the snow object, with
the Feather Tool. In the lowest tiered menu
beneath the File Menu at top of page, to the
far right, notice a “None” and right pointing
arrow. This sets the Feather pixel width. set
to what is comfortable all the way to 50 pixels
if you like, this setting works well.

Another powerful feature of Xara allows you
to combine objects in a number of ways. In 
this case, we are adding an additional area 
and desire to permanently combine as a single
object.

In the File Menu, go to Arrange/Combine
Shapes/Add Shape



You will notice that the object has lost
its texture fill and replaced by a solid
black fill. That’s because the added
portion of the combined objects was
black and on a layer higher than the
original object. To avoid this, simply
place the new object below the old, then
to the Combine procedure.

With the new object selected, click the
Fill Tool, select Bitmap from the first
drop down menu, and reselect the first
snow texture.

Aside from using photorealistic texture fills,
another way to increase the 3D depth to
the look of the map is use of shadows.

Although Xara has powerful Drop Shadow
Tool, in this part of the tutorial you are
learning to create freehand object shadows.

See the newly created shadow object, I
followed the contour in the original rock
texture to define where I want the shadow.

Keeping the object with a solid black fill, I
select the Tranparency Tool on the leftside
Tool Menu (Wine Glass icon).

In the Transparency Menu at the top of 
the application, select Linear option. By
default the transparency is applied left to 
right. Simply place your cursor above the
shadow object and drag downward past
the object’s edge.

Start the cursor a few inches above and
drag a few inches below. This allows you
to determine how much transparency across
the entire object.

The next shadow object you will make will help you create a realistic 3D drop 
in elevation from the presumed higher area. Notice the gap between the 
newly created shadow and the rock texture on the far right. I want to place a 
shadow object to give the illusion of a gradual slope.



First let’s fill the copy of the Rock layer using
the second snow texture.

Now let’s place it where it belongs, just above
the original Rock layer (which is at the bottom).
Go to Arrange/Move to Back, then select
Arrange/Move Forward. Now the new snow
object is located just above the Rock layer.

Next we want to apply a special transparency
feature that will show the layer beneath, or
through the current snow object.

Go to the leftside Tool Menu and select the
Transparency Tool. In its menu at the top
left under the File Menu, select Fractal
Clouds from the dropdown menu.

The same way you can rotate and rescale a
texture fill, you will want to make adjustments
to the scale of the Fractal Clouds. If set too
small, the pattern becomes obvious and greatly
lessens the realistic effect. You want to rescale
large enough to not recognize the pattern.

You could leave it and gain a gradual covering
of snow between covered and exposed rock
areas, but now you can enhance the patchiness
by clicking on the right facing arrow, located
four places from the far right of the menu.

The graph allows you to sharpen the edges of
the snow area, and leaving the bared rock
fully exposed. This seems far more real in 
appearance.

Go ahead a play with the adjustments to get
the snow patchiness to look right to you.

The further left the bottom slider the sharper
the difference between the filled and transparent
areas of the object become.

A similar graph menu is available under the
Color Fill Tool, allowing for adjustments between
upper and lower color or texture filled objects.



The second to the last step in this tutorial is a
repeat of a previous step. You are going to add
an Arrange/Combine/Combine Shapes by
adding more snow to the bottom of the map.

Remember to extend the area over the existing
snow, then place the layer beneath that one, 
by Arrange/Move Backward, repeat until the 
layer is actually just beneath the original snow
layer. Now Combine the Shapes.

The last step, is similar to the shadow created
on the gentle slope above, earlier in this
tutorial.

In this shadow however we will extend it all the
way to the bottom of the map. There are
several ways to create this. In this tutorial you
will learn how to use the Freehand Tool to draw
straight lines.

With the Freehand Drawing Tool selected,
place the cursor on the bottom lefthand corner
of the map. With mouse button or tablet clicked,
press and hold the Alt key, then the drag along
the bottom of the map to the opposite corner.
Notice how a straight line is mainteined. At the
corner, release the Alt key, then press it again
and drag the cursor upward along the right
side of the map until you cross the area of the
upper snow level.

Now release the Alt key, and created a scalloped
Freehand line across the snow to the opposite,
lefthand side of the map. Press and hold the Alt
key again and drag towards the originating point
in the lower lefthand corner. A “+” apppears.
When you release the cursor the object closes
and you have your new snow object.

Fill the object with the first snow texture.

Repeat the steps to create a Linear Shadow,
including making the originating point of the
Transparency at 50%, instead of 0%.

This map tutorial is now complete!



If you enjoyed this tutorial and found of any use at all, then you should 
consider signing up for my free monthly newsletter, Gamer Resource, on the 
home page of Gamer-Printshop.com website.

In it I will offer a free tutorial, free map and free map object, in addition to 
any Gamer-Printshop news and special offers.

If you consider purchasing Xara Xtreme, the download link on the first page 
is my “affiliate link”. If you purchase the software I make a 20% commission 
- its a small thing to ask, I hope.

Michael K. Tumey aka “Gamerprinter”
June 9, 2008


