
Using GIMP to Create an Artistic Regional 
RPG Map – Part 3 
This tutorial series is an updated and revised edition of an original tutorial created by RobA for the 
Cartographer’s Guild (www.cartographersguild.com). Updates and revisions to the instructions, along 
with new screenshots, were created by Megan Wiseman (“wisemoon” on Cartographer’s Guild). 

Part 1 gave instructions on how to create the basic landmass outline for your map, including some ideas 
on how to randomly generate a landmass shape if you don’t have a sketch to start with. Part 2 gave 
instructions on how to color your ocean/sea, and how to color your landmass with textured grass and 
dirt. 

This part will show you how to create mountains and forests on your map. Since RobA wrote the original 
version of this tutorial series, he has come up with a new method for creating mountains on your map. 
Therefore, instead of the original mountain-creation method, I will be putting the new method in this 
revision. You can also find a separate tutorial just for the mountain method on The Cartographer’s Guild 
site, in the Tutorials/How-To forum, labeled “Simple Mountains in Gimp”. 

NOTE: Some of the steps in Part 3 require the Felimage Noise plug-in. Click the link to download, then 
install the plug-in to your Gimp plug-in directory. Some of the steps in Part 3 require the Layer Effects 
Script-Fu script. Click the link and follow the instructions to download and install the script. 

Creating Mountains 
The technique for creating mountains is similar to the technique we used for creating the land, with a 
few additional details added for showing the height and definition of the mountains. 

1. The first thing we want to do is define where the mountains are going to be. 
a. IF you started with an original sketch, continue to step 2. 
b. IF you started with a randomized shape, skip to step 3. 

2. Move your original sketch layer up to the top of the layer stack, and change its layer blend mode 
to Burn. This shows an outline of your original sketch on top of the composite image we have so 
far. 

3. Using the Lasso Tool , select the area where you want to put the mountains. If you have 
your sketch outline up (step 2), just outline the areas from your original sketch. If you used a 
randomized shape to start, just pick an area where you want to place mountains, and create an 
outline with the Lasso Tool. 

4. Once you have your mountain areas selected, click Select>Save to Channel to save your 
selection. In the Channels dialog, right-click the new channel and select Edit Channel Attributes. 
Rename this new channel “Mountain channel”. 

http://www.cartographersguild.com/
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5. Move your original sketch down to the bottom of the stack, or just click the eye icon to hide it. 
6. In the Layers dialog, create a new layer with a Layer Fill Type of Foreground Color (black), and 

name it “Mountains Blur”. 
7. Fill your mountain selection with white. Then clear the selection by clicking Select>None. 
8. In the main image window, click Filters>Blur>Gaussian Blur. In the Gaussian Blur dialog, set the 

Blur Radius to about 100 pixels. You may want to adjust this up or down, depending on the size 
of your map and the areas you selected for mountains. 

9. Create a new layer with a Layer Fill Type of Foreground Color (black), and name it “Mountains 
Noise”. 

10. In the Channels dialog, right-click the Mountain channel, and select Channel to Selection. 
11. In the main image window, click Select>Feather to open the Feather Selection dialog. In the 

dialog, type in 40-50 pixels (again, adjust the pixel amount according to the size of your map and 
the size of your mountainous areas). 

12. In the main image window, click Filters>Render>Felimage>Noise. This opens the Felimage Noise 
dialog. In the dialog, leave the Width and Height set to 10. Change the Octaves setting to 8, 
leave the Lacunarity at 2, and set the Hurst Exponent to .30. Then click OK to close the dialog. 

13. Create a new layer with a Layer Fill Type of Foreground Color (black), and name it “Mountains 
Angular Fill”. 

14. Select the Gradient Tool. In the settings section at the bottom, click the dropdown box next to 
Shape, and select Shaped (dimpled). Make sure Adaptive Supersampling is checked, set the 
Max Depth to 4, and the Threshold is set to 3.00. Check the box to reverse the gradient, so that 
the lightest color is on the left and the darkest on the right. 

15. Click at one end of one of your mountain areas, drag toward the other end of the mountain 
ridge, then release. You should end up with a result similar to the example below.  



 

16. Change the layer blend mode on the Mountain Noise and Mountain Angular Fill layers to 
Addition. The image will appear blown out—this is expected. 

17. In the Layers dialog, select the Mountain Blur layer.  
18. In the main image window, click Colors>Levels to open the Levels dialog. In the Output Levels 

section, pull the white slider to the left until the number gets to 85. Then click OK to close the 
dialog. 

19. Select the Mountains Noise layer. Click Colors>Levels to open the Levels dialog. In the Input 
Levels section, pull the white slider to the left until it reaches the edge of the shape in the 
histogram. In the Output Levels section, pull the white slider to the left until the number gets to 
50. Then click OK to close the dialog. 

20. In the Layers dialog, select the Mountain Angular Fill layer. 
21. In the main image window, click Colors>Curves to open the Curves dialog. When it first opens, it 

will have the Linear Histogram mode on. Click the Logarithmic Histogram icon . Now you 
should see a histogram, and a line going across diagonally, from bottom left to top right. Click 
the middle of the line, where it crosses the histogram. Pull it down toward the right. As you do 
that, you will see the highlight blowout start to shrink. Play with the curve until you eliminate 
most of the highlight, leaving only a small line or a few spots. The curve should look similar to 
the example below. Then click OK to close the dialog. 



 

22. In the main image window, click Layer>New from Visible. The new layer will have a default 
name of “Visible”—rename it if it makes it easier for you to remember. 

23. Click Colors>Curves to open the Curves dialog. Pull the middle of the curve down until it 
intersects with the second-to-last or last column. You want the final section to go up very 
steeply. Look at the example below for reference. In your image, you should see the mountain 
peaks very strongly defined now. 



 

24. Duplicate the Visible layer, and name the new layer “Mountain Emboss”.  
25. In the main image window, click Filters>Distorts>Emboss to open the Emboss dialog. 
26. In the Emboss dialog, set the Elevation to 30. Leave the Azimuth and Depth at the default, or 

you can change them as you want. 
27. In the Channels dialog, right-click the Mountains channel, and select Channel to Selection. Click 

Select>Feather to open the Feather dialog. Set the Feather to 40-50 pixels. Then click 
Select>Invert to invert the selection. 

28. In the Layers dialog, select the Mountain Emboss layer. 
29. Change the Foreground color to 50% gray. Use the Bucket tool to fill in your selection with gray. 

This will smooth out the ridges on the flat ground around the mountains. 
30. Click the eye icon to hide the Mountain Blur, Mountain Noise, Mountain Angular Fill, and Visible 

layers. 
31. Select the Mountain Emboss layer. Change the layer blend mode to Hard Light. You may want to 

try changing it to Overlay, and see which blend mode looks better to you on your map. You 
should have a result similar to the example below. 



 

32. Now we’ll add some snow in the heights. Click the eye icon to turn the Visible layer back on. Set 
the layer blend mode for the Visible layer to Screen. 

33. In the main image window, click Colors>Threshold to open the Threshold dialog. 
34. In the Threshold dialog, move the black slider to the left until you have the amount of “snow” 

that looks good to you. Then click OK to close the dialog. 
35. You can blend the snow into the mountain more by putting a Gaussian Blur of about 5 pixels on 

the Visible layer. You can also lower the opacity a bit to blend it in more. 

With the mountains added, you should have a result similar to the following example: 



 
 

  



 

Creating Forests 
For forests, RobA actually recommended that people use Arsheesh’s “Photorealistic Trees in Gimp” 
tutorial, also available on The Cartographer’s Guild site. Due to this recommendation, I am including 
Arsheesh’s instructions in this revision, to replace RobA’s original instructions for creating forests. 

1. Create a new layer, and name it “Trees Noise”. 
2. In the main image window, click Filters>Render>Clouds>Solid Noise. In the Solid Noise dialog, 

set the Detail, X size, and Y size to maximum. Check the box next to Turbulent. Click the New 
Seed button to pick a random seed. Then click OK to close the dialog. 

3. Duplicate the Trees Noise layer, and rename the new layer “Trees Levels”. 
4. In the main image window, click Colors>Levels to open the Levels dialog. In the Output Levels 

section, move the black slider to the right until the number gets to about 80-85. 
5. If you started with a sketch, move the sketch layer to the top of the layer stack. The layer blend 

mode should already be Burn on this layer. If you didn’t start with a sketch, just go to the next 
step. 

6. Use the Lasso tool to select the areas where you want to have forests. 
7. Move or hide your sketch layer, if you moved it to the top in step 5. Create a new layer, with a 

Layer Fill Type of Foreground Color (black), and name it “Trees Shape”. 
8. In the main image window, click Select>Feather, and set the Feather to about 30 pixels. Play 

with the feather setting until you get the level of roundedness you want in your selection. 
9. Use the Bucket tool to fill your selection with white. Then clear your selection by clicking 

Select>None. 
10. In the main image window, click Filters>Blur>Gaussian Blur to open the Gaussian Blur dialog. 

Set the Blur Radius to about 30 pixels. Depending on the size and shape of your forests, you may 
want to go as high as 50 pixels. 

11. Make sure the Trees Shapes layer is selected, and set the layer blend mode to Multiply. 
12. Right-click the Trees Shapes layer and select Merge Down. This merges the Trees Shapes layer 

with the Trees Levels layer. Rename the merged layer “Trees Shape Threshold”. 
  



14. In the main image window, click Colors>Threshold to open the Threshold dialog. Move the black 
slider to the left until you get a shape and definition you like. Then click OK to close the dialog. 
You should have a result that looks similar to the example below. 

 

15. Click the Select By Color tool . In the settings section at the bottom, set the Threshold to 0. 
Then click in the white area of the Trees shape. This will select all the tree outlines. 

16. In the main image window, click Select>Save to Channel. Rename this new channel “Trees 
Outline”. Then clear the selection by clicking Select>None. 

17. Select the Trees Shape Threshold layer, and change the layer blend mode to Multiply. 
18. Using the Select By Color tool, select the black area surrounding the trees. 
19. Right-click the Trees Shape Threshold layer and select Merge Down. This merges the Trees 

Shape Threshold layer with the Trees Noise layer. Rename this merged layer “Trees Isolated”. 
20. Press the Delete key to delete the black area around the tree outline. Then clear the selection by 

clicking Select>None. 



21. In the main image window, click Filters>Noise>HSV Noise to open the HSV Noise dialog. Set the 
Holdness to 2, the Hue and Saturation to 0, and the Value to 30. Then click OK to close the 
dialog. 

22. Create a new layer and name it “Tree Bumps”. 
23. Fill the Tree Bumps layer with 50% gray. 
24. In the Channels dialog, right-click the Trees Outline channel, and select Channel to Selection.  
25. In the Layers dialog, right-click the Trees Bumps layer, and select Add Layer Mask. In the Add 

Layer Mask dialog, click the radio button next to Selection. Then click Add to close the dialog.  
26. Click the layer thumbnail for the Trees Bumps layer to put it in editing mode. 
27. In the main image window, click Filters>Map>Bump Map to open the Bump Map dialog. Click 

the dropdown box next to Bump Map and select the Trees Isolated layer. Click the dropdown 
box next to Map Type and select Sinusoidal. Set the Azimuth to 135, the Elevation to 30, and 
the Depth to 8. Click OK to close the dialog. Then click Select>None to clear the selection. 

28. In the main image window, click Script-Fu>Layer Effects>Drop Shadow. This opens the Script-
Fu: Drop Shadow dialog. 

29. In the dialog, set the Opacity to 75%. Set the Contour to Linear. Set the Blending Mode to 
Normal. Set the Size to 2. Set the Offset Distance to 2. Leave all other settings at their defaults. 
Then click OK to close the dialog. 

30. Create a new layer and name it “Tree Color Brown”. 
31. Click the Foreground Color swatch to open the Change Foreground Color dialog. Next to HTML 

Notation, type in 4b422f. This will give you a brownish green color. Use the Bucket tool to fill 
the Tree Color Brown layer with this color. 

32. Follow steps 24-25 to add a layer mask to the Tree Color Brown layer, using the Trees Outline 
channel. 

33. In the Layers dialog, set the layer blend mode of the Tree Color Brown layer to Soft Light. Then 
click Select>None to clear the selection. 

34. Create a new layer and name it “Tree Color Green”. 
35. Click the Foreground Color swatch to open the Change Foreground Color dialog. Next to HTML 

Notation, type in 3b580e. This will give you a dark green color. Use the Bucket tool to fill the 
Tree Color Green layer with this color. 

36. Follow steps 24-25 to add a layer mask to the Tree Color Green layer, using the Trees Outline 
channel. 

37. In the Layers dialog, set the layer blend mode of the Tree Color Green layer to Soft Light. Then 
click Select>None to clear the selection. 

38. Create a new layer and name it “Tree Color Yellow”. 
39. Click the Foreground Color swatch to open the Change Foreground Color dialog. Next to HTML 

Notation, type in 869f30. This will give you a yellowish-green color. Use the Bucket tool to fill 
the Tree Color Yellow layer with this color. 

40. Follow steps 24-25 to add a layer mask to the Tree Color Yellow layer, using the Trees Outline 
channel. 

41. In the Layers dialog, set the layer blend mode of the Tree Color Yellow layer to Soft Light. Then 
click Select>None to clear the selection. 



At this point, you should have a result that looks similar to this: 

 

This concludes Part 3 of the tutorial. In Part 4 we will be adding rivers, cities and roads to our map. 
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