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 “A medieval town map tutorial in Photoshop” by pyrandon  
http://www.cartographersguild.com/showthread.php?1150‐Award‐Winner‐A‐medieval‐town‐map‐
tutorial‐in‐Photoshop 

My purpose in this tutorial is to show how to create a Photoshop map of a medieval town 
containing a great deal of flexibility—meaning it could be either used as a photorealistic map 
or (with the help of one or more Photoshop filters) an “artistic” map. Above and beyond 
this, I also tried very hard to streamline the process so the map could be created 
exceedingly quickly. Flexibility and speed: two cartography goals worth pursuing, I think, if 
a high degree of quality can be maintained. 
 
I am assuming you know the basics of Photoshop, such as selecting items, layer 
manipulation, brush use, etc. The most advanced techniques I'll use are layer masks and 
layer styles--so nothing out of this world. However, if these seem exotic to you I'd suggest 
you perform a quick Internet search and follow a few simple PS tutorials to become 

acquainted with the program.   
 
The program I’ll use is Photoshop CS2, but I think everything I do works in both older and 
newer versions as well. For this tutorial I also use an "Rolepalying City Map Generator" 
program which can be downloaded free of charge from the developer's website (see below)-
-but you need not utilize this application if you choose to work by hand. 
 
Attached below is the basic map I'll create. At the end of this tutorial I will also show 
"artistic" variations of this basic image created in mere seconds. 
 
Finally, let me say I am a PS and cartography amateur, completely self-taught in both 
areas. If you note any suggestions, improvements, or corrections in my work, I would be 
grateful if you let me know! I write tutorials to teach myself more than for any other 
purpose, and I'd accept any and all assistance you can kindly offer. 
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I. The Basic Town Layout 

To create the basic layout of Koppollex, our medieval town-to-be, I am using the 
"Roleplaying City Map Generator", a free program available 
here:http://www.drachenzahn.de/city_map_g...city_maps.html This small application 
quickly creates the basic layout of hamlets, towns, and cities.  
 
[NOTE: If you do not wish to use this application, you could alternatively create the map by 
hand directly into Photoshop; if so, skip this step and move on, below.] 
 
Once you've opened the Generator, create a town map with any settings you prefer. One 
suggestion I have is to set the "Trees" toggle to zero (the trees the program generates do 
not gel well with the process we'll follow) [see the image, below] 
 
After you create a map which intrigues you, click the “Export Selection as an Image”; in the 
screen that pops up… 
• retain the 1 x 1 divide section  
• select a larger file (I chose 2000 px in size, but this is really big, so be forewarned.) 
• Choose “Colors”, and in that screen select colors for the major elements that will be easy 
to distinguish. These need not be the colors you will finally use, but I created a palette in 
the program that closely resembles the final colors I will use; I then saved this palette & 
now use it whenever exporting. (I also suggest setting all streets & street outlines to the 
same color, plus squares, parks, and the background set to another color.) [see image 
below] When you’re ready, save, etc., then click “Take This Time.” 
• When ready, click “Create Image” and save it! 
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 II. Importing into & Readying within Photoshop 

Now open Photoshop, then File->Open the .bmp file you just saved from the City Map 
Generator.  
 
Next isolate the map elements. While there are many ways to do this (the most versatile 
way being in saved Chanels) let's stay simple and direct: choose Select->Color Range, click 
on the background color, play with the fuzziness to be as exact as possible, then hit "ok." 
Then, with the “ants marching,” delete the background.  
 
Repeat this Select->Color Range process with the buildings, the river, etc.--although 
instead of deleting, copy-paste each element into its own, individual layer.  
 
• You'll notice I did not cut & paste the walls or towers: I found in tests it was easier to 
simply add them manually, later, if I choose to use them at all (for Koppollex I will not be 
adding walls or towers at all) 
 
When I'm done creating layers for each element, I rename the imported image's layer 
"Original bmp file," then hide it by poking out the eye. I could, in fact, delete this layer 
altogether, but I'm a "layer pack rat" and so I save it just in case. 
 
Now I have the exact same image as was imported, except with no background. So below 
the lowest layer I create a new layer ("background"), then use the paint bucket to fill a new 
layer with a solid green. [I've pasted a screenshot image, below.] 
 
NOTE: If you decide not to use the Roleplaying City Map Generator, you should basically 
start with this step: create a "background" layer and fill it, then draw on your roads, 
buildings, etc., each in its own layer. 
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III. Touch-Up & Corrections 

While the Generator is a really neat program I highly recommend, remember that it is a 
"dumb machine"--meaning it produces roads that lead nowhere, houses in the middle of 
streets, odd shapes here and there, etc. So the first true step is to examine the map and 
"correct" any anomalies by erasing &/or adding elements--each in their respective layers, of 
course.  
 
In the image below you can see that I added some buildings, roads, and water features, 
plus erased a few of the same. As the wonderful Guild members here pointed out in a works 
in progress (WIP) posting I used to quality check the finished map, I could have done much 
more to this--especially if Koppollex is intended to be a newer, more purposefully designed 
city--such as either eliminating meandering roads or adding more buildings to give them a 
purpose, but for my purposes I worked quickly and basically. (By the way, make sure to 
post your maps in the Guild's WIP forums; you'll get very useful advice!) 
 
The rivers and roads were added with a hard-edged brush of the required size, using the 
color picker ("eye-dropper") to find the right color. The buildings were added freehand and 
by dabbing with a square edged brush (see image, below, for how to get to those brushes--
and don't worry when it asks you to replace brush sets, you can always get back to the 
default brushes in the same way).  
 
And by the way, if you want to get really technical &/or plan to do a lot of this sort of thing, 
I suggest creating a set of custom "building shape" brushes that are rotated, multi-shaped, 
etc. Creating custom brushes is amazingly quick & easy in Photoshop (do an Internet search 
& you'll learn how in about 2 minutes.) 
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IV. Adding Geography 

RIVER & LAKE DETAILS 
Now in a new layer just above “rivers” called “river details”, touch up your water using 
lighter blues (even whitish-blues) with a soft-edged brush set at a low opacity.  
 
• Hint: Before beginning, you may wish to ctrl-click the “rivers” layer (or use the magic 
wand on the blue); this will select the rivers and thus prevent you from accidentally coloring 
outside the lines. 
 
• When done, you may wish to smudge the rivers to simulate a flow. You also may wish to 
use Filter>Distort>Ripple filter on it. 
• Set the layer blending mode of "river details" to Lighten & play with opacity 
• Remember that deeper water is always darker 
 
ROCKY TERRAIN 
In a new layer above “background” create a “rocks” layer—if you plan to have 
rocks/cliffs/mountains, etc..  
 
• With a large, soft brush set at medium-low opacity & flow (30%?), draw in rocky areas in 
a tan/brown color.  
• Then, with a smaller, harder-edged brush, draw in details in a darker brown (or even 
black); set your brush to a more stark opacity & flow (60% or so). It helps to draw mainly 
in the direction of the slope (i.e., draw "downhill" lines), with a few crosscutting them for 
variety! When done, set the opacity of this layer down to around 50% [see image below] 
• Finally, add a layer style of “Bevel and Emboss”—inner bevel, smooth. Also play with the 
highlight mode (I turned mine to overlay to cut on the glare!). Finally in that layer style 
box, add texture (one of the stock ones was used for mine) & contour (my range was 
dropped to 40%) [You can see my settings, below. Note from the uppermost screen that I 
already determined the angle and altitude of the shading; this will be explained below, but 
it's time to decide from which direction your light source will shine.) 
 
If, after applying, you can still see the lines you drew, either lower the layer's opacity OR 
run a Gaussian Blur on the layer. 
 
HINT: Once you like your settings in the layer style window, click the "New Style" button & 
give it a name. Next map, after drawing your squiggles, pull up the layer style menu, click 
"Styles" and you'll see yours listed. Click it and BAM! Instant style! [see image, below] 
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V. Elevations & Shadows 

The construction of this map is not 3D, although the end result hopefully shows some slight 
illusion of such. While there are a few ways of achieving a 3D "height map" in Photoshop 
(such as displacement maps), and while cartographers often demonstrate elevations by 
color (hypsometrically), I chose instead the extremely simple method of darkening lower 
elevations, then adding shadows. 
 
Create a new layer above all others called “elevations,” and set the layer blend mode to 
“multiply.”  
 
Choose a large, soft-edged brush of your choice (I like to use a textured one), set to around 
10% opacity & 10% flow. Then... 
 
• Color with black all elevation areas EXCEPT the highest "peak(s)" of the hill(s). [see 
image, below]. HINT: keep your mouse/pen held down for the entire painting of the dark 
color; this will maintain consistency with no darker overlapping. You can also run a Gaussian 
Blur on the layer if you notice overlaps or edges. 
 
• Create another new layer above "elevations", set its blending to "Multiply", and repeat the 
darkening process, darkening everything but the next highest peaks of hills. Do this over 
and over so the lowest valleys are the darkest. [see image, below]  
 
• Don’t be afraid to go dark! Later you can always lighten up with the opacity of the layer--
or even play with the brightness adjustments, levels, and such. 
 
• If you haven’t already, decide from which direction the light source is shining (in mine it’s 
upper-right) & then shadow on the opposite sides of hills, etc. This will add to the a sense of 
3 dimensionality. [see image, below] 
 
• Once done, merge all elevations layers. You may wish to play with the opacity of the 
"elevations" layer &/or run a final Filter>Blur>Gaussian Blur. 
 
• To create even more depth and interest, copy the final “elevations” layer on top of the 
original, then set the copy to a different blending mode (such as darken, color burn, etc.) 
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 VI. Building & Road Improvement 

BUILDINGS 
Let's give the buildings some life now. Ctrl-click (or Apple-click) in the “Buildings” layer to 
select the buildings, then add some random color variations with a small, soft brush; since 
the buildings are selected you should be able to draw quickly without leaving the lines.  
 
Then apply a couple layer styles: Drop Shadow first, then Bevel & Emboss. [You can see my 
settings in the image, below. The texture I'm using is simply a pattern I created out of a 
picture of a brick wall.] 
 
Now copy this "buildings" layer on top of itself. Gaussian Blur the new layer, then drop the 
opacity way down to reduce the sharp edges slightly.  
 
I also copied the buildings one more time on top of the other two, then set the layer blend 
mode to "multiply" & played with opacity. 
 
ROADS 
To create eye interest in the roads set the "roads" layer's blending mode to "overlay" and 
then Gaussian Blur it ever so slightly.  
 
Then run Filter>Texture>Texturizer, with sandstone texture set to the smallest scaling 
(50%) and verrrrry shallow relief. I also ran Filter>Artistic>Paint daubs on the roads to 
break the monotony of the sandstone.  
 
Copy this layer on top of the original and set the upper's blending mode to "multiply"; play 
with the opacity to taste. [see image, below] 
 
With a darker brown I also drew in lines for bridges, which turned out fair.  
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 VII. Vegetation 

GRASS 
Because our green "background" layer is a bit too flat, give it some life by creating a new 
layer above it called "grass". Fill that layer with an almost-white gray color, then run Filter-
>Artistic->Sponge, with settings around: brush size 3, definition 15, smoothness 4 (play 
with these to taste, of course). 
 
Next set the "grass" layer's blending mode to "multiply" & down the opacity to 60-70% or 
so. (you may also wish to run a Gaussian Blur on it very lightly to downplay the edges.)  
 
TREES 
Of the many ways to add forests, I chose to use a seamless tile I previously created from a 
picture of some trees. And may I say that creating that one pattern was an amazingly useful 
project--I highly recommend you do the same! (You can easily be taught how to create both 
a seamless tile and how to define a pattern in about 10 minutes by doing an Internet 
search). 
 
First click Layer->New Fill Layer->Pattern, and name it "trees"; in the next screen, choose 
your tree pattern at whatever scale you deem best. The entire image will instantly be 
covered with forests. Then use the paint bucket to fill the "trees" layer with solid black--all 
the forests will disappear. 
 
Now with a white brush of your choice, draw wherever you want trees, and the trees will 
appear! I used a large brush to create forest areas and smaller brush to dab in individual 
trees; I also used some of the spotty brushes to break up the solid edges. 
 
Now, your trees are placed, but they probably look very flat next to the other 3D-ish details 
of the map. So add a Drop shadow, Inner shadow, Bevel & Emboss (inner bevel, chisel 
hard) + texture set to the same tree pattern with which you filled the layer. 
 
GROUND COVER 
Finally, let's add some random shrubbery and ground cover. Create a new layer above the 
"trees" layer called "vegetation". Set layer style settings close to your "trees" layer [see my 
settings in the image, below]. 
 
Then choose a smaller stipple brush set to 40-50% opacity and fill. With various greens, 
browns, etc. either dab or draw in ground cover. Change brush tips, colors, and opacity/fill 
often for more detail and realism. (One note: the harder the brush & higher the fill/opacity, 
the taller the vegetation will appear, for the shadows and such will be more pronounced.) 
 
You can even draw on top of the trees you just placed to lend them further dimension.  
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VIII. Final Adjustments 

The bulk of the grunt work is now done, so time to step back and assess. Most likely the 
first thing you'll notice is that the entire map is quite dark. The best way to lighten it up is 
adding an adjustment layer as the top layer in your stack (Layer->New Adjustment Layer); 
which type you choose is up to you: Brightness/Contrast is easiest, Levels allows a little 
more control, and Curves boasts most control but can be tricky. 
 
You could also play with the color scheme in this same way by adding an adjustment layer 
for Color Balance. Even the Photo Filter can offer some interesting, subtle color effects. 
 
Also, if colors look a bit too neon/pastel for your tastes, add an adjustment layer for 
hue/saturation. 
 
This is really just the "play" stage, so try a few things to near your vision for your map. 
 
Below is the before & after version of my map, showing the adjusted colors and 
brlightening. 
 

 



17 
 

IX. Fields & Finishing 

FIELDS 
First, I decided last-minute to add farm fields. I created a new layer called "fields" just 
below the "elevations" layer, set its blending mode to "overlay," and filled it entirely with a 
dirt-brown color. Then I ran Filter->Texture->Texturizer on it, set to canvas with high 
scaling (125%) and low relief (10). Then place a layer mask on it and fill with black so all 
the "fields" disappear.  
 
Then use a white color to paint in fields where you want them. To finish them off, blur the 
mask a bit (make sure the mask is highlighted in the layers display, not the brown!), and 
play with Image->Adjustments settings such as brightness/contrast, levels, and color 
balance. If you wish, you can also blur the fields themselves, plus use stippling brushes to 
enter tiny little rows of crops, etc. Opacity of the layer could be adjusted too, to blend with 
the rest of the landscape a bit. 
 
TEXT 
Next choose a font and label your locations. When you're done, ctrl-click them all and 
Layer->Merge Down. Then place a layer style of drop shadow, making settings fit your 
tatses. I also placed a very slight guassian blur (3 px.) to soften the hard edges. 
 
If you wish, you can also increase the canvas size (Edit->Canvas Size) and frame the map 
by creating and filling a new layer as the lowermost of the stack. 
 
IMAGE SIZE 
If you plan to print this map, size really will not matter: you'll print it to the largest size you 
can manage. If working in a digital environment only, think about how closely you'd ideally 
want the viewer to zoom. This style of map is not intended to be looked at through a 
microscope, thus I scaled my image down to 900px square; this way 100% zoom is the 
perfect, closest distance I'd like someone's eye to get a clear shot. 
 
For all intents & purposes this is a finished, usable, "realistic" map! [see image, below] In 
the next post, though, I'll give some other ideas for post-production filters and fun tweaks 
to transform "Koppollex" into a more "artistic" map. 
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X. Filter Fun 

Now, the above style is perfect for a finished map, but I myself prefer to utilize the power of 
Photoshop's many filters to create a somewhat more "artistic" appearance. With filters the 
sky is the limit as to which look you choose for your finished map. 
 
PRE-FILTERING 
Before filtering do the following: 
 
1. Group all your text (if in more than one layer) by ctrl-clicking them all, then clicking the 
"create a new group" folder in the layers window 
 
2. In the same way also group the entire map ASIDE FROM your matte/frame. I named my 
new group "map elements".  
 
3. Drag the group containing your map elements to the "create a new layer" button, which 
creates a new group. Then Layer->Merge Group. I renamed mine "map". This layer will 
serve as your copy-able map upon which you can run multiple filters; you will not change 
this layer. 
 
4. Copy the new "map" layer and rename it "filtered map". This layer will be the actual layer 
you will filter. 
 
5. Hide both "map elements" and "map", and lock all layers other than "filtered map". 
 
[see image, below, for how your layers window should end up.] 
 
 
FILTERS 
The first is one of my favorites: poster edges. The layers are, from top to bottom: 
1. Dry brush--very smudgy, set to 30% opacity 
2. Poster edges, set darker/thicker. This was then Gaussian blurred up, & set to 30% 
opacity 
3. Poster edges, thin & clean 
 
The next is basically the same, but using the watercolor filter. This one is too smudgy to be 
used as a detailed location map, perhaps, but I think it has a pleasing appearance. 
1. Watercolored with medium shadows & high detail, then blurred slightly. Layer set to 
"lighten" & 50% opacity 
2. Watercolored with 0 shadow & high detail. Blurred only about 3 px. 
 
These are two of a million varieties, my friends. You could even go back and filter individual 
elements or combinations of the original elements, such as I did with the third map. For that 
one I chose the basic roads, homes, elevation, river, rocks, & trees, copied them onto one 
layer set to "multiply", then Filter->sharpen->sharpen edges about 5 times. Then I ran the 
cutout filter. For the background I changed my black frame to brown & ran the texturizer 
filter as canvas. I also messed with opacity and doubled up a couple filters, but you get the 
idea. 
 
There you are! I hope you found this tutorial at least mildly useful! Take care. 
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