
This process was created with Adobe CS4, using Illustrator and Photoshop.

Meshon’s Cobblestone Roads tutoRial



1. Build a cobblestone brush in Illustrator
Note: The link for the files that go with this tutorial is https://dl.dropboxusercontent.com/u/64705797/

Battlemaps/MCS-tutorial/MCS_tutorialFiles.zip

First, set up an Illustrator document to build your brush in. I use a grid for reference and, because I am 
building maps at 100px per inch, I set up my grid accordingly (100px divisions with 10 subdivisions each 
of 10px). In this example I will be building a road 300px wide but you can see in the screenshot that I 
have a variety of sizes of cobblestone patterns constructed.

I’m trying out different configurations for the cobblestones, but for this tutorial I’ll use the same pat-
tern as I had in my Ruined Neighbourhood map, which appears on the cover page of this tutorial.

Start drawing the cobblestones. I’m using a rounded rectangle 30px high in this example, with a white 
fill and a black stroke, but you might also try rectangles with hard corners (the stroke is really just to help 
me see what I’m doing). I’m orienting the cobblestones horizontally here, but you can also see in some of 
the other layouts on the page that I’ve tried vertically as well. It’s really just your personal preference and 
how you want your cobblestone road to look. The spacing between the stones is also a matter of prefer-
ence. I’ve found that if your roads are going to have a lot of curves and direction changes, or run in circu-
lar patters, the horizontal arrangement works nicely and the spaces between the cobbles reduce distortion 
on curved paths. I have 10px of space between the cobblestones. This is probably the maximum I’d want 
to use for my resolution and, having used this size I would recommend trying a little smaller spaces, even 
down to 5px space between the cobbles. As you can see in the sample brushes I’m currently experiment-
ing with cobbles that are closer together.



Note the two red lines. This is where I’m going to cut the stones. If all of your cobbles line up at one 
end it will make a noticeable seam when you place them on a longer path. There will probably still be 
seams which ever way you do it, but having the ends of the cobbles line up gave me less satisfactory 
results.

When you trim the stones at the end, make sure they remain open so that when the stones are repeated 
end to end they join up properly. I use the pen tool in illustrator to add anchor points along the cut line 
and then just delete any points that lie outside that space. There are a variety of ways to cut shapes in Il-
lustrator. 

It’s time to make the stones a bit less regular. I use the Roughen effect with fairly low settings. Play 
around until you get stones that you like the look of. At this point it is safe to get rid of the stroke. I also 
use a fill of 50% grey, or R=128 G=128 B=128 because this grey works well if you want to edit the colour 
of your cobblestones later. Keep in mind that we will be importing this whole mess into Photoshop, so 
you can easily change the colour there. White fill is also a solid option, though it makes your work harder 
to see if you have a white background.



Next, select all your new cobblestones. Make sure your Brushes window is open and select New 
Brush. Set it to be a pattern brush and name it what you like. I set the fit to Approximate Path and the 
colorization method to Tints and Shades. This isn’t strictly necessary, it just makes the brush a little more 
versatile when you use it to draw your streets, as you can set the colour of the cobblestones by changing 
the stroke colour. Again, Photoshop is where the actual colouring will be done, so it isn’t a crucial choice.

Save your brush library (so it can be used in other documents). Now you have a brush, it’s time to 
draw roads!



2. Lay down paths for the roads
Create a new document that is the size that you want your final map to be. I’m using a small one for 

the example, just 1200px by 1200px. Then draw a large rectangle outside the borders of your document. 
This will be a reference border to allow you to paste your roads into Photoshop and have them all line 
up but still allowing you to crop the edges properly later. I added 400px on each side, so the large square 
is 2000px by 2000px. It is important to make sure that the stroke for your reference box is set to Align - 
Inside. The reference box should have a stroke but no fill (I think it does have a fill in my screenshots, but 
it shouldn’t have one).

Now draw some lines where you want your roads to go. If you want the roads to continue off the edge 
of your map, make sure that they extend out past the map border but not past your reference border.

If you haven’t already, open the brush library that contains your cobblestones. Select the path and then 
click on a brush style.

If you want roads to intersect, make sure they overlap completely. They can be cleaned up in Pho-
toshop. If you want to make circles I would recommend using a narrower brush more than once, with 
concentric circles. The brushes tend to distort more if you use a wider one.

At this point I would recommend changing the colour to white, which will make the cobbles easier to 
fiddle with in Photoshop.



3. Paste the layers into Photoshop
Now it’s time to open Photoshop. Create a new document that is the same dimensions as your refer-

ence border. My resolution is set to 72dpi because I will be using this map in MapTool. If you need a 
higher resolution (for print as an example) some of the layer effects I use will have to be tweaked. They’re 
pretty much all about personal preference though, so tweak away!

To get my roads into Photoshop I just copied and pasted (as pixels), one road path at a time, along with 
the reference border for each path. I haven’t tried other methods of importing the file, but you need to 
make sure each path you drew in Illustrator is on a separate layer.

Now it’s time to clean up the places where the cobblestones overlap. This will be pretty straightfor-
ward if you only have a couple of layers, a bit more involved if you have a lot. The first thing is to ar-
range your layers that have the bits of your cobblestone roads on them. Place the most important layers at 
the top, being those layers that you would like to preserve completely. If you have a particular path that 
makes a nice curve, or a circle that you would like to keep intact, put those layers at the top.

Select the bottom-most of the cobblestone layers. Now control-click or command-click (depending 
on  your OS) on the thumbnail for the cobblestone layer immediately above the one you have selected 



to make a selection based on the pixels. At this point it is probably worthwhile to give the layer a colour 
overlay that makes it visible since you’ll need to be able to see what you are doing, and white kind of 
blends in. I just use a layer effect to change the colour so that it is easy to change back again later. Now 
expand the selection by a few pixels, between 5-10, and then invert the selection. Now hit delete, making 
sure that the layer you are deleting from is the layer below the one you got the selection from.

If you like you can zoom in and round off any sharp edges that are left. If you have more intersecting 
layers, move up to the next one and repeat the process. If you want your paths to interlock more you’ll 
have to do a bit more close-up work. My goal with this process was to make it fairly quick, so I’m happy 
to just have the less important paths butt up against the more important ones (important being a measure 
of relative aesthetics!).

This tutorial uses a fairly simple pair of paths but I will just include a note on making more complicat-
ed paths and even filling large areas. You can lay in a whole bunch of paths when you are working in your 
Illustrator document. In my Ruined Neighbourhood map I used short bits of paths to fill gaps thus allow-
ing me to use a relatively narrow cobblestone road pattern to fill some large areas. It just takes awhile to 
clean up, but you can really get precise on how the stones are laid out, even creating a sort of ornamental 
pattern with them if you like. Just be prepared for a more involved process cleaning up the joins once you 
bring the whole lot into Photoshop.

Once you have all your cobblestone layers cleaned up so that there are no overlaps  you can create a 
single layer that includes all your cobblestone paths. You could merge the layers, especially if you are in-
terested in conserving file size. You could also use the ctrl-click/cmd-click trick, also holding down shift, 
and click on each layer thumbnail that has cobblestones. As long as you hold down the shift key, each 
selection will be added to the previous one. Once you have a selection of all the cobblestones you can cre-
ate a new layer and fill the selection. This preserves all your original paths, just in case. I’m cautious that 
way, but it’s probably not necessary and you may prefer to just merge all your cobblestone layers.



Once you have all your cobbles on one layer, create a new layer under that one and use ctrl-click again 
to select the pixels on the cobblestone layer. Expand the selection by about 10 pixels. The goal is to get a 
solid area that lies behind the entire cobblestone path. This area can be a background for the cobblestones 

and will also be used in edging the roads with stuff. You might have a few small holes within the cobble-
stone underlay; just fill them with a brush.

Now you can add some layer effects to make the cobblestone layer look like something. I use a few 
different ones but this step will largely depend on your personal preferences, general colour scheme etc. 
I’ve included screenshots of the effects I used.

Maybe add a background now, don’t you think? You can also add some layer effects to the underlay to 
simulate whatever it is that is underneath your cobblestones.



If this result is what you need then consider yourself done! Crop the file to the size you want it and add 
whatever it is that your roads lead to!

4. Adding a mess
I’ve gotten a few things sorted out since I started this tutorial, so the additional files actually include 

the two patterns and styles that I am using in the next part of this tutorial, as well as my debris brush.
The next step is to add some mess to the edges of the road. To start, create some new layers; I use 

three. You should have one for debris and one for some mossy overgrowth. I add a second debris layer to 
give a little depth to the rubble piled along the sides of the road.

Once you have the new layers, use ctrl-click/cmd-click to make a selection from the pixels of your 
underlay layer, which should make a selection that falls just outside the edges of your cobblestones.



Switch to the paths tab and click Make work path from selection button at the bottom of the window. 
You should see a fine line appear around your cobblestones, which is your work path.

Next set up the rubble brush. I’ve included the one I used; basically you just need a brush that includes 
a few geometric shapes. Click on the brush tool and then have a look at the Brushes window. Set the 
brush to about 50xp. Again this dimension will be partially dependent on the resolution you are working 
in. My final size is 100px per square (or per inch) and so I’m using a brush size of half that.

I’ll be honest. When it comes to Photoshop brushes, I know next to nothing, so I’ve just played around 
with the settings until I got something that worked for me. Basically you just want to randomize where 
the little bits fall. I’ve included the settings I used, but I heartily recommend just playing around with 
these settings, especially if you haven’t done so before. If you have, you’re ahead of me!

Set your foreground colour to white and select your debris layer, or your lowest debris layer if you 
have more than one. Switch to the pen tool ,right click on the path in your image window, and select 
Stroke path. Choose Brush. Yay, blotches!



Do the same thing with your other debris layers if you have them, and with the grawss layer, but re-
duce the brush size a bit each time. I went with 35px for the second (upper) debris layer and 25px for the 
mossy grass.

Now you can apply the mossyGrass and smallRubble styles to the appropriate layers. If the style file 
isn’t going to work for you, here are the settings I used. The patterns used in the styles are included, but 
they are available on cgtextures.com if you want to get your own. The rubble:

And the grass:

The next step is optional and will add some overgrowth to the cobblestones.



5. Growing moss/grass in the cracks
The goal of this final step is to get some mossy/grassy overgrowth on the cobblestones. It was the one 

step I hadn’t found a consistently satsifying way to get the results I wanted. What I’m after here is to get 
the moss mostly in the spaces between the stones, with a little bit growing over the stones here and there. 
Finally I realized that using the method from OldGuy’s tutorial on making rough coastlines was exactly 
what I needed. I’ll repeat the steps here but the original (and elegant) method can be found here: http://
www.cartographersguild.com/tutorials-how/9056-award-winner-creating-realistic-coastlines.html.

Create a new layer for the moss to grow on and the select the pixels of your cobblestone layer while 
keeping your new layer active, using ctrl/cmd-click on the thumbnail for the cobblestone layer.

Fill the selection with white on your new layer (Edit > Fill) and then invert the selection (not the im-
age). Fill the inverted selection with black.

Now it’s time for OldGuy’s method. First, choose Filter > Noise > Add Noise, choosing Gaussian and 
monochromatic, with the value set to about 100.



Next do Filter > Blur > Gaussian Blur and set it to 2.

Choose Image > Adjustments > Threshold and move the slider until you get the edges of the cobble-
stones a bit eroded with some speckles on the stones.

Invert the layer, turning the white to black and black to white. Using the magic wand selection tool, 
click on one of the black areas to select it and then choose Select > Similar to select all the black areas.



Hit delete to clear all the black pixels away so you can see your stones peeking through. Now create a 
new layer to build up some shapes to remove some more moss (the white area on the Overgrowth layer is 
what will become the moss).

Make sure your foreground colour is black and the background colour is white. With the new layer 
active, do Filter > Render > Clouds. Next do Filter > Render > Difference Clouds. You can repeat the Dif-
ference Clouds step a couple of times.

Finally, repeat the steps from the coastline tutorial: Noise, Gaussian Blur, and Threshold.



When you’re done playing with Threshold you’ll want a noisy layer that is mostly black. Click on one 
of the black areas with the Magic Wand selection tool, and do Select > Similar to select all the black. Hide 
this layer, select your Overgrowth layer, and hit delete. The white that is left will be your moss. I just cop-
ied the layer style from the Road Edge Grass layer and just got rid of the Stroke layer effect, but you can 
play with layer effects until the moss patches look right to you.

Also, once I had the moss layer coloured I felt like there wasn’t quite enough so I clicked the layer 
thumbnail to select the pixels, did Select > Modify > Expand, and set it to 1px, then filled with white.

Of course, now there are patches of moss all over your background! This may be exactly what you 
want, but getting rid of it is easy. 



Remember the cobblestone underlay layer? With the Overgrowth layer active, 
ctrl/cmd click its thumbnail of the underlay layer to select the pixels and then click 
the Add Vector Mask button at the bottom of the layers tab. Done!

It’s worth noting that, depending on your preference, you can do the entire moss 
step using masks instead of deleting pixels. I tend to do both, a little haphazardly. 
I like layer masks but I don’t always think to use them, and I’m not an expert with 
them. The choice is yours.

Finally, crop the image to your desired size and enjoy! I hope this tutorial has 
been useful. Please post any feedback on making it better in the thread on the Car-
tographer’s Guild forums:

http://www.cartographersguild.com/tutorials-how/23161-meshons-cobblestone-
streets-tutorial.html

Thanks for reading!

Cheers,
Meshon


