Results 1 to 8 of 8

Thread: Similar Plugins for GIMP on Linux?

  1. #1
    Guild Novice Facebook Connected
    Join Date
    May 2012
    Location
    A, A
    Posts
    10

    Help Similar Plugins for GIMP on Linux?

    I use GIMP on my computer, on which I run Ubuntu linux instead of Windows. I've been practicing on some of the tuts here (which are awesome, by the way!). The main problem I've run into is when I start to work on mountains and such, where the prevalent methods seem to incorporate plugins such as Felimage which, unfortunately for me, are specifically for Windows.

    I was interested in finding out if anyone else does their work on linux and have found similar plugins or other workarounds for this problem. I would love to learn about these methods.

  2. #2
      RobA is offline
    Administrator RobA's Avatar
    Join Date
    Apr 2007
    Location
    Niagara, Canada
    Posts
    5,532

    Default

    The source is provided: http://prdownloads.sourceforge.net/f...ar.gz?download

    From the INSTALL file:

    The simplest way to compile this package is:

    1. `cd' to the directory containing the package's source code and type
    `./configure' to configure the package for your system. If you're
    using `csh' on an old version of System V, you might need to type
    `sh ./configure' instead to prevent `csh' from trying to execute
    `configure' itself.

    Running `configure' takes awhile. While running, it prints some
    messages telling which features it is checking for.

    2. Type `make' to compile the package.

    3. Optionally, type `make check' to run any self-tests that come with
    the package.

    4. Type `make install' to install the programs and any data files and
    documentation.

    5. You can remove the program binaries and object files from the
    source code directory by typing `make clean'. To also remove the
    files that `configure' created (so you can compile the package for
    a different kind of computer), type `make distclean'. There is
    also a `make maintainer-clean' target, but that is intended mainly
    for the package's developers. If you use it, you may have to get
    all sorts of other programs in order to regenerate files that came
    with the distribution.

  3. #3
    Guild Novice Facebook Connected
    Join Date
    May 2012
    Location
    A, A
    Posts
    10

    Default

    Ok, I downloaded the file and got as far as configuration. From there, when I try to run make or makefile, it just says 'command not found'. If I try to sh it, it says 'Can't open file'. Any thoughts?

    Note: I'm using Ubuntu 12.04 if that helps any
    Last edited by Mercutio361; 08-14-2012 at 05:09 PM.

  4. #4
      Hai-Etlik is offline
    Guild Expert Gracious Donor Hai-Etlik's Avatar
    Join Date
    May 2009
    Location
    48° 28′ N 123° 8′ W
    Posts
    1,109
    Blog Entries
    1

    Default

    Make sure you installed the build-essential package

    Code:
    sudo apt-get install build-essential

  5. #5
    Guild Novice Facebook Connected
    Join Date
    May 2012
    Location
    A, A
    Posts
    10

    Default

    I followed your advice and installed the build-essential package, and I'm still getting the same problem, and getting a bit frustrated. Maybe it's just an incompatibility with my system's version?

  6. #6
    Guild Novice Facebook Connected
    Join Date
    May 2012
    Location
    A, A
    Posts
    10

    Default

    I checked back over the configure statements upon running it, and found this in the messages. It seems to say that the version I'm using ( the latest, 2.8 ) is later than the program is updated for.

    Code:
    configure: error: Package requirements (gimp-2.0 >= 2.2.0 gimpui-2.0 >= 2.2.0) were not met.

  7. #7
      Hai-Etlik is offline
    Guild Expert Gracious Donor Hai-Etlik's Avatar
    Join Date
    May 2009
    Location
    48° 28′ N 123° 8′ W
    Posts
    1,109
    Blog Entries
    1

    Default

    Quote Originally Posted by Mercutio361 View Post
    I checked back over the configure statements upon running it, and found this in the messages. It seems to say that the version I'm using ( the latest, 2.8 ) is later than the program is updated for.

    Code:
    configure: error: Package requirements (gimp-2.0 >= 2.2.0 gimpui-2.0 >= 2.2.0) were not met.
    Oh, do you have the GIMP development packages installed?

    Code:
    sudo apt-get install libgimp2.0-dev

  8. #8
      goucher is offline
    Guild Novice goucher's Avatar
    Join Date
    May 2009
    Location
    Toronto, Canada
    Posts
    5

    Default

    Thanks that's just what I needed to do.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •