Results 1 to 2 of 2

Thread: Trouble with my homemade GIMP brush pipes, background is black instead of transparent

  1. #1
      Falconius is offline
    Guild Adept Falconius's Avatar
    Join Date
    Jul 2013
    Location
    Israel
    Posts
    431

    Default Trouble with my homemade GIMP brush pipes, background is black instead of transparent

    Hiya, So I've made a ton of brushes for my mountain set and I layered them up with transparent backgrounds so that I wouldn't have to go through the 70 or so different brushes. The problem is when I tried em out in GIMP they are not animated, and the background is black instead of transparent. I'm not sure what I'm doing wrong. As individual .gbr files they are doing fine.

    In the image below is an example of the animated brush set (it stays on the first layer no mater if I drag or click multiple times), and next to it is one of my regular brushes which are transparent and working fine. The files that all of my stuff is coming from are greyscale, square, with transparent backgrounds. I started with the background layer and moved up. I've tried a couple of things to try and fix the export to no avail. When I open up the brush pipe as an image, all the layers are there but they all look similar to the one in the example, with the black background.

    If anyone can help me understand or help me to do it correctly from the start it would be much appreciated.

    Cheers.

    ----------------------------------------------------------------------------------
    Update: Ok So far here is what I've discovered. The reason the black appears in the greyscale animated brushes is because it erases the alpha channel when you save it to .gih . The animated brushes seem to have to be done in RGB even if they are black and white. They still seem to take on the foreground colour though so that is good. The other animated black and white brushes they've included seem to bear this out.

    And the reason they weren't animating is because of a silly misunderstanding of my own. For each cell of animation you also have to include a rank. So for a brush of 21 layers you have to have 21 in your ranks.
    -----------------------------------------------------------------------------------
    More: Actually they dont take on the foreground colours. The included animated brushes do for some reason. Somehow they seem to have a working alpha channel for grey images.
    -----------------------------------------------------------------------------------
    Solution: For the grey animated brushes you have to go through the layers and remove the alpha chanels. You will still retain the transparencies but your brush will now take on foreground colours.
    Attached Thumbnails Attached Thumbnails Trouble with my homemade GIMP brush pipes, background is black instead of transparent-brush-trouble.jpg  
    Last edited by Falconius; 07-25-2013 at 10:22 PM. Reason: Solution

  2. #2
      RobA is offline
    Administrator RobA's Avatar
    Join Date
    Apr 2007
    Location
    Niagara, Canada
    Posts
    5,532

    Default

    Hi Falconius.

    To add some clarity, both gih (animated brushes/tunes/image hoses) follow the same logic:

    -a source without alpha channel(s) will convert the greyscale into transparency and paint with the foreground colour. 50% grey will end up 50% transparent.
    -a source that is RGBA will paint exactly as created with transparency and colours regardless of the foreground colour.

    -RobA>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •