Results 1 to 10 of 10

Thread: CC3 Help: Changing Terrain Fill Density

  1. #1

    Help CC3 Help: Changing Terrain Fill Density

    I'm working on a much larger version of this map;

    http://www.squaremans.com/images/conquest/Urland.jpg

    And I'm running into a lot of problems all, I suspect, a result of my ignorance. But specifically I'm trying to create forests of different scale. Big forest at one scale that looks good at one view, many smaller forests at another scale that look good in a different view.

    I figured out how to get the size of the trees scaled down in the Forest Terrain Fill, but the density is the same as the larger scale, which means what I get is an extremely sparse forest. Not only does nothing seem to change the density of the fill, the term "density" does appear anywhere in the UI or help files, as far as I can tell. At least not in relation to this issue. Which makes me think I'm asking the wrong question.

    Any help would be greatly appreciated!

  2. #2
    Community Leader NeonKnight's Avatar
    Join Date
    Aug 2007
    Location
    Surrey, Canada, EH!
    Posts
    5,025

    Default

    Can you post an example of what you are getting, and maybe a screen shot of your SYMBOL FILL options menu screen. Would help to replicate/fix.
    Daniel the Neon Knight: Campaign Cartographer User

    Never use a big word when a diminutive one will suffice!

    Any questions on CC3? Post them with CC3 in the Subject Line!
    MY 'FAMOUS' CC3 MAPS: Thunderspire; Pyramid of Shadows; King of the Trollhaunt Warrens; Demon Queen's Enclave

  3. #3

    Default

    http://www.squaremans.com/images/Urland01.jpg

    That map should illustrate the problem. At the top, big forest. Looks good. Large symbols, densely packed together.

    Then in the middle is a smaller forest, using the same tool, but note all the white space. My expectation is the white space would be filled with trees, a la the larger forest above. I think I've successfully scaled the symbols in the fill, but not the rate at which it draws them. So both forests have the same density, but since the forest in the middle has smaller trees, there's more white space.

    Symbol Fill doesn't seem to do anything, when I monkey with stuff like X and Y spacing using the Deciduous Fill, which it says is currently selected, all that happens is I get a green background under my forest when I draw it, and I think the green background green trees, not part of this map style. Here's the Symbol Fill box.

    http://www.squaremans.com/images/Urland05.jpg

    When I select Terrain Fill, I can bring up the Advanced Options and this is what I get.

    http://www.squaremans.com/images/Urland02.jpg
    http://www.squaremans.com/images/Urland03.jpg
    http://www.squaremans.com/images/Urland04.jpg

  4. #4
    Community Leader NeonKnight's Avatar
    Join Date
    Aug 2007
    Location
    Surrey, Canada, EH!
    Posts
    5,025

    Default

    OK, I'll need to research it a bit to find the answer (don't usually use the Symbol fill myself)
    Daniel the Neon Knight: Campaign Cartographer User

    Never use a big word when a diminutive one will suffice!

    Any questions on CC3? Post them with CC3 in the Subject Line!
    MY 'FAMOUS' CC3 MAPS: Thunderspire; Pyramid of Shadows; King of the Trollhaunt Warrens; Demon Queen's Enclave

  5. #5

    Default

    Well if you can figure it out, I'll owe you a coke. I'm good for it!

  6. #6

    Default

    I hope no one minds if I bump this thread. This problem is vexing me. I am sorely vexed.

  7. #7
    Community Leader NeonKnight's Avatar
    Join Date
    Aug 2007
    Location
    Surrey, Canada, EH!
    Posts
    5,025

    Default

    OK, some answers to your Questions, all inline.

    Quote Originally Posted by mattcolville View Post
    http://www.squaremans.com/images/Urland01.jpg

    That map should illustrate the problem. At the top, big forest. Looks good. Large symbols, densely packed together.

    Then in the middle is a smaller forest, using the same tool, but note all the white space. My expectation is the white space would be filled with trees, a la the larger forest above. I think I've successfully scaled the symbols in the fill, but not the rate at which it draws them. So both forests have the same density, but since the forest in the middle has smaller trees, there's more white space.

    Symbol Fill doesn't seem to do anything, when I monkey with stuff like X and Y spacing using the Deciduous Fill, which it says is currently selected, all that happens is I get a green background under my forest when I draw it, and I think the green background green trees, not part of this map style. Here's the Symbol Fill box.

    http://www.squaremans.com/images/Urland05.jpg

    When I select Terrain Fill, I can bring up the Advanced Options and this is what I get.
    http://www.squaremans.com/images/Urland02.jpg

    OK, here you have listed the BASIC CUSTOM DRAWING TOOLS. These cover what will happen when you draw something, This menu selection is quite intense, and allows for all sorts of customization.

    http://www.squaremans.com/images/Urland03.jpg

    Here, you have shown the FRACTAL POLYGON Option, it has nothing to do with the FILL STYLE, what this deals with is if you are drawing a POLYGON, it will determine how often and how sever it will fractalize the path between points you have placed on the map. Example, if it was a straight line with a single click for start and another for end, this option would determine how often and sever that line is bent between the two points. To get an idea use the FRACTAL PATH tool (on the right with the LINE, CIRCLE, PATH tools), to see what I mean.

    http://www.squaremans.com/images/Urland04.jpg

    This displays the properties. Unfortunately, the HELP file does not contain much info on this.

    Now, there is a HUGE (26 meg) user manual available from the Profantasy Site http://dl1.profantasy.com/library/fi...rManualNew.pdf. You need to logged in to get it tho. Pages 70-73 coves this tool.

    What you did not display, is how the FOREST FILL is actually executed, and is coverd in the MACRO section of the tool. I'll be honest, I don't play with macros, as I don't fully understand the complexities of it, and usually just find work arounds.

    Now, to fix your Forest Issue, you COULD try running the FILL WITH SYMBOLS command (DRAW -> FILL WITH SYMBOLS) This allows you to play with the symbols you use to fill a polygon. There should be some way to change the symbol size, and I am still researching it, so it might take me a while.

    The one thing I can't figure out (cause sometimes I am thick) is how you managed to draw the symbols smaller in Example #1
    Last edited by NeonKnight; 02-24-2011 at 07:36 PM.
    Daniel the Neon Knight: Campaign Cartographer User

    Never use a big word when a diminutive one will suffice!

    Any questions on CC3? Post them with CC3 in the Subject Line!
    MY 'FAMOUS' CC3 MAPS: Thunderspire; Pyramid of Shadows; King of the Trollhaunt Warrens; Demon Queen's Enclave

  8. #8

    Default

    Wow, thanks! It seems like the answer is "you can't do what you want to do with those tools," which...you know, it is what it is. I'll check out the MACRO setting but it seems a little advanced for me.

    Thanks again for the help!

  9. #9

    Default

    I discovered the problem! Posting here in case other people run into the same thing.

    Feeling like it was just a problem beyond me, I threw out my old map and started again. While making the new map with a new strategy, I experimented with the Default Scale in Drawing Properties...which I'd used before...and this time it worked! It worked exactly as it should. Big forest, small forest, no problems. None.

    I'd experimented a lot with the default scale in the previous, problematic map, and I sheepishly concluded that I have obviously changed some combination of settings I didn't understand and gotten myself into trouble. But now the issue was solved, so I start happily mapping away.

    Then I discovered the problem. Every once in a while, when switching between two different Default Scales...it stops working. The new scale doesn't "take" and the symbols come out the same size as the old scale and when I then monkey with it to get it down, I get the results you saw above. Sparse forests for no reason.

    If I quit the app and reload the map, everything goes back to normal. I think it *may* be related to switching apps during a session? Not sure. I haven't robustly tried to duplicate it, but it crops up regularly when switching scales and I can reliable fix it just by quitting and starting again.

    Thanks again for you help, hopefully others with this problem in future will see this thread and be helped.

    I'll post my final map when it's done.

  10. #10
    Community Leader NeonKnight's Avatar
    Join Date
    Aug 2007
    Location
    Surrey, Canada, EH!
    Posts
    5,025

    Default

    Well, I glad you figured it out. Something new for me to experiment with.
    Daniel the Neon Knight: Campaign Cartographer User

    Never use a big word when a diminutive one will suffice!

    Any questions on CC3? Post them with CC3 in the Subject Line!
    MY 'FAMOUS' CC3 MAPS: Thunderspire; Pyramid of Shadows; King of the Trollhaunt Warrens; Demon Queen's Enclave

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •