I have been following the Hand-Drawn Map Tutorial (for the Artistically Challenged) by Gidde @ the Cartographer's Guild. It was working out well for me up until he talks about rivers. I drew out my rivers an then he says (im going to quote it off the tutorial)

Step 2. Clean up the edges
Right-click on the River layer in the layers dialog, and click “Add Layer Mask…”. Check the box next
to channel, select Sea in the dropdown, check the Invert Layer Mask checkbox, and hit Ok. Next,
right-click the River layer again, and click Apply Layer Mask.

Now when i do that, all the rivers just vanish. Im just not sure if i missed a step or if im doing something else wrong. Any one have any idea why its doing that? Figure i will skip the step for now, but if his tip would make them look better, im all for using it. Assuming i can get it to work.