Results 1 to 6 of 6

Thread: [CC3] Error "No matching draw tool"

Threaded View

  1. #1
    Guild Applicant trechriron's Avatar
    Join Date
    Jun 2008
    Location
    South Puget Sound WA
    Posts
    3

    Help [CC3] Error "No matching draw tool"

    I also submitted my issue to PF tech support, but thought I might tap the experts here.

    First, this install routine for CC3 is ridiculous and the 300+ dollars I have wrapped up in the software makes it even more stressful for me. Just wanted to drop that out up front because I am a tad frustrated.

    I was getting this error when clicking any button for a draw tool. So I thought maybe I installed it wrong. So I uninstalled everything and re-installed based on the PF online FAQ for CC3 + Compatibility Updates.

    Here is the order I installed my products;

    1. Install CC3
    2. Install Patch 1
    3. Install compatibility updates (CU)

      • City Designer
      • Symbol Set 3
      • Cosmographer Pro
      • NOTE: Cosmographer CU will not install until patch 1 is installed - It launches an error saying you need a higher version to install it, hence the reason I installed first "out of order"
    4. Install SS1, SS2, SS3
    5. Install DD3, Cities!, Cartographers Annual 2007
    6. Install Patch 3
    7. Install Patch 5


    I tried uninstalling Patch 1 and reapplying the patches again in order. I still get the error on some buttons - "No matching draw tool". So all of the CC3 draw tools work, and some SS3, DD3, CDpro, and CMpro buttons work and others error out.

    • Should I install DD3 before patch 1?
    • Is Patch 5 all inclusive of previous patches or should I be applying patches in order?
    • Do I need to install the full version of the software relating to a compatibility update or only the CU by itself? Example – do I install CD Pro and\or SS3 after the compatibility updates?


    Is this just a known defect (bug) and does someone have a fix? Any help would be appreciated!
    Last edited by trechriron; 08-01-2008 at 07:20 AM. Reason: spelling

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •