Results 1 to 10 of 23

Thread: Putting myself though a Blender

Threaded View

  1. #1
    Software Dev/Rep Redrobes's Avatar
    Join Date
    Dec 2007
    Location
    England
    Posts
    4,807
    Blog Entries
    4

    Post Putting myself though a Blender

    Its time I did it.

    Its time I actually took a real good look at the application Blender which is the Open Source full on, packs a mighty punch, 3D rendering package.

    I have been using my 3D laser scanner and it dumps out zillions of points and poly's and its all geared up for light-wave 3D which is an excellent package but my copy is old and there is one major drawback which I assume they have fixed and that is it has a 65K polygon limit. Its also single threaded and lacking many if not all that important features. I like the sound of particle effects, volumetric lighting and radiosity... mmmmm

    So I know a bit about 3D apps but nothing at all about Blender so I have started to play with it. Several people have asked about it - including me - on these boards and so I thought that I would share my learning experience so that others can get a leg up on it and also maybe if anyone else would like to follow and path-beat the way with me then you might pick up some extra points that I miss and can add to the blog. So lets get this straight - this is no tutorial !!!

    So lets start and try to get it up, render something of the right size and save out a render. After that I would like to be able to model some basic shapes and then texture them up. After that we will see where we go.

    So here is the base page:
    http://www.blender.org/

    and the download is here...
    http://www.blender.org/download/get-blender/

    I looked for a 64bit version but I could not find any so I DL'ed the x86 version and it installed easily. I set the local files directory to the install directory but in all else I just chose defaults.

    When its run you are given a screen with a cube on it and a camera and a light all set up. Even this I think is an improvement over the last time I tried it as I could not figure out the UI.

    Looking at the blender wiki...
    http://wiki.blender.org/index.php/Main_Page
    http://wiki.blender.org/index.php/Bo..._Blender_(text)
    ... help and intro it talks about the UI being a bit different from most apps. This is true and the main reason why I gave up last time. Interestingly it says that you should use it with one hand on the mouse and one hand on the keyboard. They call this ohomohok !

    That was interesting because Del and I were discussing how my ViewingDale uses this approach and he gave up on the UI for the same reason that I gave up on Blender. I know that I can use my app real fast and this is what blender is saying is why they do it this way too. So I really need to do this now just to prove a point to myself !

    The next thing they go on about is the mouse. They insist on a 3 button mouse and bizarrely its the middle button that allows you to move around. I.e. No move no App. No 3 button mouse no App. This is a bit annoying as I use a trackball which does have the third button but its not so comfortable as the other two. Anyway - be warned - you NEED it to run.

    Ok we install and run it up and you get two windows on the task bar, one is a DOS type on windows machines and the other is the main app. You leave the DOS window alone or minimize it. If you shut it then the main app shuts down.

    Now we have our cube on the screen. First thing I tried was the middle mouse button which does do what it says but the backdrop is set to Ortho (parallel background lines) view not perspective so you can get pretty confused about depth right off the bat. Whether its the norm I don't know but I set it to perspective view using the menu. The number keypad controls the view so 7,1,3 does top bottom and side and 0 is camera view. I like this a lot. On LW you look at all four at once but you quarter the view space. Having a quick way to get around the object is very very handy.

    So we have our camera view and if you hit render on F12 then it renders it. Its smallish but seems alright. Hit F10 and get the scene properties and there is the render size and format. So 4000x3000 for me with PNG. Great. F12 again....

    So wheres the save render option ? Took me a while to figure this out but the render window is supposed to stay open so now we have three on the task bar. Press F3 and you get the option of where to save and what filename. Its obviously not a standard windows UI here so there are some foibles which I would guess those Linux guys would not see. Save the file and there it is and I can look at it in PSP. Great so job done.

    When I shut it down and reopened it was back to small render and JPEG again so I changed back again and this time saved the scene using the menu at the top of the main window. That seemed to work when I opened the app and loaded the scene in again.

    So far so good. More to come I expect in the next few days.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	CG_UI_Pic1.png 
Views:	55 
Size:	8.2 KB 
ID:	6876   Click image for larger version. 

Name:	CG_UI_Pic2.png 
Views:	39 
Size:	42.1 KB 
ID:	6877   Click image for larger version. 

Name:	CG_UI_Pic3.png 
Views:	34 
Size:	21.9 KB 
ID:	6878   Click image for larger version. 

Name:	CG_Pic1.png 
Views:	49 
Size:	3.9 KB 
ID:	6879  
    Last edited by Redrobes; 10-06-2008 at 04:11 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •