Results 1 to 5 of 5

Thread: [CC3/DD3] Revisiting the "No Matching Draw Tool" undocumented-feature!

  1. #1

    Post [CC3/DD3] Revisiting the "No Matching Draw Tool" undocumented-feature!

    I am having problem with CC3/DD3 showing me a "No Matching Draw Tool" error.
    I just don't understand it.
    I create a new map with my own dimensions, but based on a DD3 template/style.
    I create a floor area using the "Floor" button.
    I click on "Add Corridor" button but decide not to, so select "Cancel"
    Now when I try to draw a floor with the "Floor" button I get the error. (It didn't come up the first time!)

    I am SO confused by CC3 that I have abandoned the software SO many times due to it's vertical learning "curve."

    Any help and a shot of vallium would be appreciated!
    Last edited by wigwam; 11-22-2008 at 11:34 AM. Reason: speeling

  2. #2
    Community Leader NeonKnight's Avatar
    Join Date
    Aug 2007
    Surrey, Canada, EH!


    Hmmm, I tried to recreate your error message, and I can't.

    So, my first question would be: What Version of CC3 are you running? I currently have version 3.22 (downloading 3.24 now).

    Another thought is this: Right Click on the FLOOR TOOL button. The pop-up should display Floor Samples and state it's STYLE is Dungeon DD3 Color.

    If not, then likely something is happening when you click on the ADD CORRIDOR button to deselect the DD3 styles.
    Last edited by NeonKnight; 11-22-2008 at 04:29 PM.
    Daniel the Neon Knight: Campaign Cartographer User

    Never use a big word when a diminutive one will suffice!

    Any questions on CC3? Post them with CC3 in the Subject Line!
    MY 'FAMOUS' CC3 MAPS: Thunderspire; Pyramid of Shadows; King of the Trollhaunt Warrens; Demon Queen's Enclave

  3. #3
    Guild Novice
    Join Date
    Oct 2008
    Isle of Wight, England


    I tried this too as I often get this error.
    In my case this happens when I have a map based on the Dungeon templates but you try to use a CC3 tool such as land mass or rivers (on battlemaps etc). Like NeonKnight, I also cannot get the error to happen using the same template.

    I have had terrible trouble getting DD3 to work correctly on my Vista machine, but I found that uninstaling DD3 and reinstalling it with the latest v7 patch has helped a lot.

    I found that working through the DD3 manual gives you the basics and there are some excellent tutorials (and lots of helpful people) here to help you take it further, so dont give up

    edit: just a thought, but does it happen with a predefinded template?
    Found in a computer dictionary..Recursive - see recursive...
    Software used - Campaign Cartographer 3, DD3 and CC3.

  4. #4


    Thanks guys - will make those checks as soon as I'm back on my main PC....

  5. #5


    I think I've sorted it out. I have the 2007 annual and am selecting Starship floor styles. This sets the Drawing Style to something based off Cosmographer - which I DON'T have. Although the bitmaps and layer effects are ok, the system whinges from this point onwards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts