Page 3 of 3 FirstFirst 123
Results 21 to 30 of 30

Thread: [HowTo] python plugins and GIMP with Windows

  1. #21
      RobA is offline
    Administrator RobA's Avatar
    Join Date
    Apr 2007
    Location
    Niagara, Canada
    Posts
    5,532

    Default

    I know it is late in this thread, but I installed using this pack assembled by photocomix over at gimptalk:
    http://photocomix-resources.devianta...asier-74889017

    It is one bundle with all all the compatible version installs and a step by step guide...

    -Rob A>

  2. #22
      Karro is offline
    Guild Artisan Facebook Connected
    Join Date
    May 2008
    Location
    Atlanta, Georgia, United States
    Posts
    928

    Post

    Quote Originally Posted by RobA View Post
    I know it is late in this thread, but I installed using this pack assembled by photocomix over at gimptalk:
    http://photocomix-resources.devianta...asier-74889017

    It is one bundle with all all the compatible version installs and a step by step guide...

    -Rob A>
    Yeah, I just found the same pack last night. Although, upon deeper examination, the items included are the same versions I pulled down from Sagenlicht's links, but at least here it's all already together.

    The only (minor) problem is that the GTK+ included is, I think, very out of date (the others don't appear to be so much).

    But, I'm second-guessing my conclusion that GIMP's more current GTK+ installing over the older GTK+ is the source of the problem. I'd have to do some testing to see for sure, but I began to suspect last night that part of the problem was that I chose a poor test-case of a python add-in to verify whether python for GIMP was working. I discovered later last night that Sagenlicht's GURM, which I had been using as a quick test, requires some additional hacking in the .py and .ini files to make work... Still haven't gotten that one script working, but all the others I've downloaded so far are now working like a charm!

    Thanks everybody for your patience with this guy who "knows just enough about computers to be dangerous, but not enough to be useful".
    I think, therefore I am a nerd.
    Cogito, ergo sum nerdem.

    Check out my blog: "The Undiscovered Author"
    It's the story of a writer... follow me in my simple quest to get published, and share your own writing stories, adventures and writerly tips.

    Pimping my worldmap here. Still WIP... long way to go, but I'm pretty proud of what I've done so far...

  3. #23

  4. #24
      x0brandi is offline
    Guild Applicant
    Join Date
    May 2009
    Posts
    1

    Help Couldn't reinstall gimp.

    I found the forum for GURM through many Google searches.
    Downloaded it.Installed it.
    & it didn't show up in my filters folder in Gimp.
    Looked around & found this thread.
    I tried downloading Python 2.5.4 since 2.5.2 isn't there. It wouldn't install correctly. I went ahead & Googled Python 2.5.2 & download it instead. After this, I deleted gimp.
    I tried going back to gimp.org & downloading it, but it gave me an error message, something to the extent of not complete file. Then I tried quite a few mirrors, no luck. I tried deleting the Python, PyCairo, PyGObject and PyGTK. I did a system restore & got Gimp back, but it was 2.4 & was missing some files, i.e. no menu bars. I finally got Gimp to download, but still can't get this plug-in to work. I know this may seem like a bunch of useless information, but i wanted to make sure all my steps were taken into account if necessary, plus my memory is pretty bad. Any help would be greatly appreciated. By the way, everything else seemed to download correctly.

  5. #25
      Doc_Waldo is offline
    Guild Novice
    Join Date
    Dec 2010
    Location
    Boise, ID
    Posts
    11

    Default

    Does anyone know how to install this plugin on a mac?

    --Doc

  6. #26
      Notsonoble is offline
    Guild Adept Gracious Donor Notsonoble's Avatar
    Join Date
    Sep 2008
    Location
    Lubbock
    Posts
    318

    Default

    Has anybody checked to make sure this all works with updated python 2.7.2 and gimp 2.6.11?
    My D&D/Roleplaying Blog Making a new effort to update every two weeks!
    Gimp Gradient Basics

  7. #27
      jfrazierjr is offline
    Community Leader jfrazierjr's Avatar
    Join Date
    Oct 2007
    Location
    Apex, NC USA
    Posts
    2,963

    Default

    Many non Core plugins are messed up in 2.7 since the API is changed. I am using 2.7.2 on linux and miss it a lot.
    My Finished Maps
    Works in Progress(or abandoned tests)
    My Tutorials:
    Explanation of Layer Masks in GIMP
    How to create ISO Mountains in GIMP/PS using the Smudge tool
    ----------------------------------------------------------
    Unless otherwise stated by me in the post, all work is licensed under a Creative Commons Attribution-Noncommercial 3.0 United States License.

  8. #28
      Notsonoble is offline
    Guild Adept Gracious Donor Notsonoble's Avatar
    Join Date
    Sep 2008
    Location
    Lubbock
    Posts
    318

    Default

    Yeah, and I just found GIMP for windows can't even see python 2.7, found a 2.6.6 installer to try.
    My D&D/Roleplaying Blog Making a new effort to update every two weeks!
    Gimp Gradient Basics

  9. #29
      Sagenlicht is offline
    Guild Journeyer Sagenlicht's Avatar
    Join Date
    Jul 2008
    Location
    Germany
    Posts
    249

    Default

    I updated all links in the first post.
    My Map Challenge Entries

    I use GIMP for all my maps.

    GIMP scripts and plug-ins overview


    Everything I post on this site uses the Creative Common Attribution-Noncommercial-Share Alike license. Only exception to this are any pyhton scripts which use the GPL.

    If you are using any of my posted stuff just use your rep stick on me

    Should you be interested in using anything I posted on commercial purpose drop me a pm.

  10. #30
      Sagenlicht is offline
    Guild Journeyer Sagenlicht's Avatar
    Join Date
    Jul 2008
    Location
    Germany
    Posts
    249

    Default

    Quote Originally Posted by Notsonoble View Post
    Has anybody checked to make sure this all works with updated python 2.7.2 and gimp 2.6.11?
    GIMP requires Python 2.6 or Python 2.5

    When Python 2.6 came out it did take some time till GIMP supported that as well, so that aint a surprise Python 2.7 aint supported yet. I doubt Python 2.7. will be supported in GIM 2.6 at all.
    My Map Challenge Entries

    I use GIMP for all my maps.

    GIMP scripts and plug-ins overview


    Everything I post on this site uses the Creative Common Attribution-Noncommercial-Share Alike license. Only exception to this are any pyhton scripts which use the GPL.

    If you are using any of my posted stuff just use your rep stick on me

    Should you be interested in using anything I posted on commercial purpose drop me a pm.

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •